Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-06-2005, 09:33 PM
Registered User
 
Join Date: Apr 2004
Posts: 17
722.118 ('81 300D) transmission problem (bucking/jerking/surging in Drive)

My 300D with 722.118 transmission is bucking/jerking/surging forward in Drive
when stopped at a light which is the main problem. (like someone is gently
rearending you trying to shove the car forward). a couple times from stop,
before the bucking/jerking/surging forward became very serious, the
transmission didn't engage, and ended up revving very high (surge?) before
finally engaging. (I have to shift out of Drive at a light to get relief from
all the bucking/jerking/surging ......)

I've looked at the B2 piston, and it seems intact. actually i've disassembed
things, and can't seem to get the b2 all the way out, but the inner side
and outer side seem to be a solid piece. also the b2 band seems to
be in one piece - NOT sure how to tell if the b2 band is bad.

I had searched the archives, and it seems to confirm the later 722.3
transmissions are the ones that have the more common b2 failure, and there
are only a couple possible mentions of 722.18 b2 or b2 band failure.

SO... any ideas?

-o2pilot

Reply With Quote
  #2  
Old 09-07-2005, 12:19 AM
Registered User
 
Join Date: Aug 2005
Location: Northwest
Posts: 48
Trans Problem

Really it sound like either a problem in the valve body or clutch packs going out.

I had the same thing happen in my 240D. Has the transmission been overfilled??

Excessive pressure can cause these sytems but usually by now its too late. I don't think its the B2, I changed the seal in mine and it still did it.
__________________
Ryan
1985 300D Turbo Diesel
1984 200 Euro
Reply With Quote
  #3  
Old 09-07-2005, 01:14 AM
Registered User
 
Join Date: Apr 2004
Posts: 17
re: trans problem

Hi. it seems to me that the fluid was over filled when I had
a look after the problem started. got the car, drove
down from SJ to LA and then on the way back this problem
developed. car only has 60k.
in LA the surging forward was barely noticeable, and by
the time we got back, it wasn't that tolerable when you're stopped
at a intersection. also a couple times along the way
it wouldn't go into gear until revved high.

i've taken apart the valve body in order to examine the b2 piston,
and it seems pretty clean, fluid was pretty clean....
then again, I'm a newbie as far as auto transmissions and
Mercedes go.....

-o2pilot

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'81 300D Transmission problem, flare 2-3 davidhoward Diesel Discussion 8 04-11-2005 11:07 AM
Anyone have this transmission problem and a solution for it lietuviai Diesel Discussion 13 04-05-2005 10:28 PM
Transmission problem Ironhead Diesel Discussion 8 03-27-2005 10:35 AM
'90 300E transmission problem BamaMB Tech Help 0 06-16-2004 12:16 AM
85 300D Automatic Transmission Linkage adjustments Carrameow Tech Help 1 09-17-2001 08:44 AM



All times are GMT -4. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page