Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-29-2005, 01:44 PM
Registered User
 
Join Date: Aug 2005
Posts: 56
Unhappy 91 300D 2.5T, Oil in coolant, From tranny??

I bought a 91 300D 2.5 Turbo in September. Beautiful car, but clunked badly when shifting. Spent $1300 at an independent shop to get engine and transmission mounts, and differential bushings replaced, and got work done on transmission vacuum controls. Still clunked a little.

Two days ago the tranny suddenly started slipping in first gear. Took it back to the shop. They say it needs a new transmission, and they found oil in the coolant. They think it is coming from the transmission oil cooler.

Is this a reasonable theory? It seems more likely to me to be from a bad head gasket or cracked head. Engine oil looked fine last time I changed it. There is no sign of coolant in the tranny oil.

The shop wants $4600 to install a rebuilt tranny and new radiator. I can't afford that, so I think I'll have to park it until it stops raining out here and install a rebuilt or used one myself. I really hope I don't need a new head also...

Thanks for any info..

Max Behensky

82 240D (slow but steady)
91 300D 2.5 Turbo (beautiful, fast, and nothing but trouble)
Reply With Quote
  #2  
Old 12-29-2005, 03:28 PM
boneheaddoctor's Avatar
Senior Benz fanatic
 
Join Date: May 2004
Location: Hells half acre (Great Falls, Virginia)
Posts: 16,007
Tranny coolant in the radiator is easy to spot...and means you need a new radiator....you could have gotten water in the tranny too.....trans fluid has a pinkish hue to it....like a mahogony color in a overflow tank....engine oil is greyish...........
__________________
Proud owner of ....
1971 280SE W108
1979 300SD W116
1983 300D W123
1975 Ironhead Sportster chopper
1987 GMC 3/4 ton 4X4 Diesel
1989 Honda Civic (Heavily modified)
---------------------
Section 609 MVAC Certified
---------------------
"He who fights with monsters might take care lest he thereby become a monster. And if you gaze for long into an abyss, the abyss gazes also into you." - Friedrich Nietzsche
Reply With Quote
  #3  
Old 12-29-2005, 03:41 PM
Registered User
 
Join Date: Dec 2002
Location: RI shore
Posts: 2,937
$4600 is pretty spendy IMHO. Call Sun Valley Transmissions and see what it would cost to ship a complete rebuilt unit to your door. BTW, that trans might have the TV valve that needs to be replaced when it gets contaminated with coolant. Maybe you could fix it cheaper, but I wouldn't let it sit with suspect coolant contaminated fluid. Change fluid and filter and get it warmed up. Coolant is no good for the friction plates and bearings.
__________________
'82 300SD - 361K mi - "Blue"

"Good judgement comes from experience. Experience comes from bad judgement."

listen, look, .........and duck.
Reply With Quote
  #4  
Old 12-29-2005, 05:58 PM
Hatterasguy's Avatar
Zero
 
Join Date: Nov 2002
Location: Milford, CT
Posts: 19,306
Its been known to happen with these cars.

If you have the time and ablility I'd pull your old trans out and have it rebuilt. The radiator you have got to replace their isn't much you can do about that. Just make sure to flush the cooling system well to get all the oil out of it. Also make sure to flush all of the old trans fluid out off the cooler lines so you don't screw up your freshly rebuilt trans.

How does the tranny fluid look? I'd think it should look like a strawberry shake with coolant in it.
__________________
2017 Chevy Silverado 1500 LTZ
2007 Tiara 3200

"No free man shall ever be debarred the use of arms. The strongest reason for the people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government."
-Thomas Jefferson
Reply With Quote
  #5  
Old 12-30-2005, 04:39 PM
Registered User
 
Join Date: Aug 2005
Posts: 56
Thanks for the help guys. I got the car back from the shop yesterday. They said the tranny fluid looked perfect when drained, and there was no sign of metal or band material in the pan. The engine oil also looks perfect to me. I didn't personally see any oil in the coolant when I checked it. I'm not sure what to think now.

I'm going to go through things carefully myself. I'm going to disconnect the transmission oil cooler and test it with compressed air and see if it holds pressure or I get bubbles in the radiator. I may do an oil analysis on the engine and tranny oil looking for glycol contamination.

I'm not convinced the tranny is really shot, or contaminated anyway. I'm going to see if I can figure out which band is slipping and why. I'll post the results when I find out something...

Max Behensky
Reply With Quote
  #6  
Old 12-30-2005, 04:47 PM
Registered User
 
Join Date: Dec 2002
Location: RI shore
Posts: 2,937
Quote:
Originally Posted by mbehensky
I'm going to go through things carefully myself. I'm going to disconnect the transmission oil cooler and test it with compressed air and see if it holds pressure or I get bubbles in the radiator. I may do an oil analysis on the engine and tranny oil looking for glycol contamination.

I'm not convinced the tranny is really shot, or contaminated anyway. I'm going to see if I can figure out which band is slipping and why. I'll post the results when I find out something...

Max Behensky
smart. Good for you.
__________________
'82 300SD - 361K mi - "Blue"

"Good judgement comes from experience. Experience comes from bad judgement."

listen, look, .........and duck.
Reply With Quote
  #7  
Old 12-30-2005, 04:56 PM
Registered User
 
Join Date: Jan 2005
Posts: 121
my 92 2.5 had small thumps when shifting in this colder weather. if i warmed it up a couple minutes, and drove down my road slowly, i was fine for the commute. just got it back from my mechanic. he put in a new fan clutch for me. the transmission is A LOT worse now.

could just a couple shifts (D to R, R to D) on a cold engine make a big difference? i don't know what he could have done to change it this drastically, nor what i'm going to do to get it back to normal.

i HATE putting money into this car...

david
__________________
newfane, vt
84 300td 223k modified greasel conversion (sold)
92 300d 2.5 185k with frybrid kit
Reply With Quote
  #8  
Old 12-30-2005, 06:14 PM
Registered User
 
Join Date: Aug 2005
Posts: 56
After doing some research, I'm hopeful that I may have a B2 piston problem. Here's why:

1. The failure was catastrophic. It went from never slipping in first gear to always slipping in first gear at a single stoplight. This suggests something broke rather than wore out.

2. The symptoms seem to match pretty well. Slips a lot in first gear, occasionally on shifts to higher gears.

3. There was no other sign of problems with the tranny fluid or in the pan.

This can be fixed on the car, if it is really this. There was a comprehensive FAQ on the subject, but the original link is gone. There is a web archive, however. Check out here:

http://web.archive.org/web/20041026013432/http://business.baylor.edu/Richard_Easley/autofaqs/b2piston.htm
Reply With Quote
  #9  
Old 12-30-2005, 06:34 PM
dieseldiehard's Avatar
Dieseldiehard
 
Join Date: Oct 2002
Location: Bay Area No Calif.
Posts: 4,176
Thanks for the link. I wonder how many transmissions have been rebuilt when all that was necessary was a new B2 piston?
Your indy might have been guessing about the type of oil they saw in the coolant, presuming some was really present. That bears investigation though.
I would suspect a headgasket possibly. Just keep a close eye on it.
An oil analysis is a good thing for a reference point anyhow.
__________________
'00 E320 (wifes car), '95 E320 Wagon my favorite road car. '99 E300D wolf in sheeps body, '87 300D Sportline suspension, '79 300TD w/ 617.952 engine at 367,750 and counting!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page