Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2006, 09:34 PM
Diesel Meck.
 
Join Date: Sep 2005
Location: Dublin, CA
Posts: 35
Rear Defroster

The rear defroster on my 77' 300D doesn't work because the wires on the side of the glass were cut. They were because the window needed a new seal. What is the best way to reconnect these wires so it will work again. It gets very cold in the morning and the window gets iced over and makes it hard to see. I tried to solder the two wires together but it still doesn't work. The light on the switch works so I believe it is getting power so I don't see the problem.
Reply With Quote
  #2  
Old 01-05-2006, 10:10 PM
pberku's Avatar
Registered User
 
Join Date: Oct 2003
Location: Montreal, Canada
Posts: 737
Don't solder, you will ruin it, and possibly shatter your glass.

There are repair kits available to repair these wires, Should be available at Autozone or similar
__________________
'95 E300 Diesel, 264,000 Miles. [Sold it]
Reply With Quote
  #3  
Old 01-05-2006, 10:15 PM
Diesel Meck.
 
Join Date: Sep 2005
Location: Dublin, CA
Posts: 35
Quote:
There are repair kits available to repair these wires, Should be available at Autozone or similar
I've looked and found nothing, that is why im asking here. But thanks anyway.
Reply With Quote
  #4  
Old 01-05-2006, 10:19 PM
pberku's Avatar
Registered User
 
Join Date: Oct 2003
Location: Montreal, Canada
Posts: 737
I am in Canada and they do have them here, so I am sure that they have them in the US as well.

I'll go tomorrow to our equivalent of your Autozone (Canadian Tire) and see who makes them. I'll let you know.

Phil
__________________
'95 E300 Diesel, 264,000 Miles. [Sold it]
Reply With Quote
  #5  
Old 01-05-2006, 10:19 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by SumDude
I've looked and found nothing, that is why im asking here. But thanks anyway.
Perhaps somebody could provide a link to the appropriate or similar kit so he knows what to look for...
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #6  
Old 01-05-2006, 10:23 PM
pberku's Avatar
Registered User
 
Join Date: Oct 2003
Location: Montreal, Canada
Posts: 737
Quote:
Originally Posted by JimmyL
Perhaps somebody could provide a link to the appropriate or similar kit so he knows what to look for...
If you do a Google on "Defroster repair kit" you will find many. I just did. Here is one link I found: http://www.frostfighter.com/ff_products.htm

There are many more
__________________
'95 E300 Diesel, 264,000 Miles. [Sold it]
Reply With Quote
  #7  
Old 01-05-2006, 10:24 PM
Diesel Meck.
 
Join Date: Sep 2005
Location: Dublin, CA
Posts: 35
That would be nice.
Reply With Quote
  #8  
Old 01-05-2006, 10:33 PM
Diesel Meck.
 
Join Date: Sep 2005
Location: Dublin, CA
Posts: 35
ok the replys are nice and thanks. But my wires are solid metal straps not just wires with connectors. do I have to pull at interior off to put new "metal strips"?
Reply With Quote
  #9  
Old 01-05-2006, 10:38 PM
Craig
Guest
 
Posts: n/a
Quote:
Originally Posted by SumDude
I've looked and found nothing, that is why im asking here. But thanks anyway.
I found one of those kits at a NAPA store a couple of years ago.
Reply With Quote
  #10  
Old 01-06-2006, 02:47 PM
Zerohour3k's Avatar
Diesel Enthusiast
 
Join Date: Sep 2005
Location: Ocean County, NJ
Posts: 367
Since we're on the topic..

I have a slight problem with my defroster, as well.. maybe one of you can help me troubleshoot it. When I press the button, it usually stays on (and flickers..) for about 15 seconds, before shutting off. Press it again after that, and it refuses to go on at all. The defroster itself is fine, because if I hold the switch in the on position, it works without a problem (granted, two of the grid lines are dead, but thats an easy fix).

My guess, is that the relay is shot. I removed the switch when I first encountered the problem, and gave it a thorough cleaning.. and the problem persisted as if I hadn't done a thing. So my question is.. where can I buy one of the defroster relays for a 1984 300D Euro. I assume it's the same relay as the US model.. but even that, I cannot find anywhere. I'd go to a junkyard, but I don't trust relays that have been sitting out in the elements for 20 years.

Thanks in advance for any help.. am I right with my suspicians?
Reply With Quote
  #11  
Old 01-06-2006, 03:26 PM
dannym's Avatar
I'm not here
 
Join Date: Oct 2004
Location: Deltona, Florida
Posts: 2,360
This might work:

http://www.radioshack.com/product/index.jsp?productId=2104395&cp=&kw=conductive&parentPage=search

Actually it says "Repairs most window defrosters".

I'm sure these repair kits can be found at auto part stores. If you don't find it at one try another.

Danny
__________________
1984 300SD Turbo Diesel 150,000 miles

OBK member #23

(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(")_(") signature to help him gain world domination
Reply With Quote
  #12  
Old 01-06-2006, 03:31 PM
dannym's Avatar
I'm not here
 
Join Date: Oct 2004
Location: Deltona, Florida
Posts: 2,360
call Phil......his number is on the home page here.
He'll hook you up.

Danny
__________________
1984 300SD Turbo Diesel 150,000 miles

OBK member #23

(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(")_(") signature to help him gain world domination
Reply With Quote
  #13  
Old 01-06-2006, 04:30 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,043
Aren't the defroster lines on these windows inside the multilayered glass? Thats what I thought......the only way they can get damaged is at the sides, or if the window shatters.....
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 79k - mine - (OC-80,500)
'17 Metris(VITO!) - 9k - wifes (OC-10k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'89 420SEL 166k - mine (OC-167,000)
'01 E320 - 172k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 49k - dad's (OC-52,000)
'09 E350 4matic Sedan - 137k - Brothers (OC-141,500)
Reply With Quote
  #14  
Old 01-06-2006, 06:09 PM
Zerohour3k's Avatar
Diesel Enthusiast
 
Join Date: Sep 2005
Location: Ocean County, NJ
Posts: 367
I keep hearing things about the defrosters shattering the rear window. Is this at all common? Any tell-tale signs that it's about to happen? Something about having a rear window shatter out on you, is slightly unnerving.
Reply With Quote
  #15  
Old 01-07-2006, 12:55 AM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,043
I've never heard of them just plain shattering, mine hasn't.... I think the biggest danger is when installing or removing the window and applying uneven pressure to the curved glass, then they have been known to shatter, quite often....especially if they are old and the layers are separating...

I shattered the passenger door window on my car trying to get the jammed regulator/seal to come undone, all the sudden I heard a "BSSSHHH" and all of the glass discentegrated into little ball bearing size pieces, and they were rounded!! It was both cool, and sad, at the same time. Thankfully autoglass specialists came and replaced it two days later for a total of $128, not bad! They happened to have one in stock in their GR warehouse.
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 79k - mine - (OC-80,500)
'17 Metris(VITO!) - 9k - wifes (OC-10k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'89 420SEL 166k - mine (OC-167,000)
'01 E320 - 172k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 49k - dad's (OC-52,000)
'09 E350 4matic Sedan - 137k - Brothers (OC-141,500)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page