Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2006, 12:57 PM
Registered User
 
Join Date: Jan 2006
Posts: 292
Battery Light will not turn off

My battery Light will not turn off. The alternator is charging ok, the battery is new,
and the light is still on. In my last 300SD when the alternator was going
you could rev up the motor and the light would go dim or go almost out. And
the battery would be half dead when you try and start her. But everything
works good but the light is still on. Please help. Jay

81 300SD 141 miles
81 300SD 136 miles
83 300SD 247 miles
Reply With Quote
  #2  
Old 03-09-2006, 01:10 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
I'd guess a bad regulator or a short in your wiring on the wire from the lamp to the regulator. If you unplug the low-voltage lines to the regulator, does the lamp extinguish?
Reply With Quote
  #3  
Old 03-09-2006, 02:09 PM
Biodiesel300TD's Avatar
|3iodiesel300T|)
 
Join Date: Dec 2004
Location: Albany, OR
Posts: 4,845
Do you headlights brighten a little when you step on the go pedal? If so your voltage regulator might be bad. Its a simple replacement and if it hasn't been done in the past it probably needs one anyway.
__________________
Andrew
'04 Jetta TDI Wagon
'82 300TD ~ Winnie ~ Sold
'77 300D ~ Sold
Reply With Quote
  #4  
Old 03-09-2006, 02:47 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,043
Quote:
Originally Posted by Biodiesel300TD
Do you headlights brighten a little when you step on the go pedal? If so your voltage regulator might be bad. Its a simple replacement and if it hasn't been done in the past it probably needs one anyway.

Wouldn't it be if they don't brighten a little when stepping on the pedal, I know that my system generates about 13.1 volts at idle with the headlights on, and goes up to 14.1 volts if I rev it over 2,000rpm. (I have a voltmeter gauge in my car) if the lights do not brighten when reving it a little, I'd think there's a voltage regulator problem (not charging and not giving enough juice).
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 79k - mine - (OC-80,500)
'17 Metris(VITO!) - 9k - wifes (OC-10k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'89 420SEL 166k - mine (OC-167,000)
'01 E320 - 172k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 49k - dad's (OC-52,000)
'09 E350 4matic Sedan - 137k - Brothers (OC-141,500)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page