Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-25-2006, 06:01 PM
Nate Stanley's Avatar
Registered User
 
Join Date: Jul 2000
Location: Watsonville, Ca
Posts: 399
Help! 100 degrees and no air!

To all,
I finally got my '82 SD on the road, the biggest main issues are front suspension and a dead climate control. Otherwise a great cruiser!!

As for the CC, here is what I have--and I'll worry about the air conditioning later, once I get some air moving in the cabin.

1) No air movement thru any of the registers. Not even at defrost setting. 70MPH gives you a weak ram effect thru the dash outlets.
2) No power to blower motor at the motor connector.
3) Blower will work if given 12V. Brushes check out ok.
4) Bypass fuse kit installed at slot # 11, wiring has been hot but I have +12V at the fuse and continuity across the fuse.
5) Slot # 11 shows melted plastic around the fuse mounting clips.
6) Temp control wheel does regulate heat.

I know I need to check out the pushbutton unit, and there is a blower control module near the glovebox
that needs to be checked out.

My questions are:-

In the event my working pushbutton unit from the 300D fails to help, Has anyone ever worked up a test routine for the blower control module?
Has anyone ever repaired that module successfully?
And am I missing anything else in the circuit that may kill power to the blower motor?

Thanks to all who can help!!
__________________
Nate Stanley
(Currently Benzless)
1985 F-250 6.9l 170K
2009 SCION XB 36.5K
2003 LS430 78K
2012 Kubota B 2320
Reply With Quote
  #2  
Old 07-25-2006, 06:18 PM
Motorhead's Avatar
Registered User
 
Join Date: Dec 2002
Location: Ca.
Posts: 971
Try the push button assy. from the other car first. If it works, take the one out of the SD apart and check the solder joints. Look for any hot spots especially the joints for the little load relay on the circuit board.
__________________
My Truck.. 2007 DODGE, 5.9 Cummins, 6spd stick, 4X4. My car..1977 240D, OTHER WHEELS...1955 VW Oval window bug, European Delivery (Holland) with a 1700cc, 2 barrel, Porsche drum brakes. 1939 WILLYS Pick-up. 1967 Triumph 200cc Tiger Cub. 1976 Honda 550F 4cyl Motor Cycle.
Reply With Quote
  #3  
Old 07-25-2006, 06:50 PM
Nate Stanley's Avatar
Registered User
 
Join Date: Jul 2000
Location: Watsonville, Ca
Posts: 399
Thanks, I'll try that first.
__________________
Nate Stanley
(Currently Benzless)
1985 F-250 6.9l 170K
2009 SCION XB 36.5K
2003 LS430 78K
2012 Kubota B 2320
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page