Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-08-2006, 11:20 PM
SirNik84's Avatar
Registered User
 
Join Date: Nov 2005
Location: Sacramento, Ca
Posts: 1,466
Victory! Over Heat in the 300SD

Well for those of you who read my first post:
Time for a new radiator for my 84 300SD?
Well my 300SD is solid as a rock, and cool!
I changed everything. the radiator weighed about 3 times as much as the new one... I'm assuming that it was all clogged... then the water pump... she spun great... but the impeller was eroded and had large pits in it... and the holes that were suppose to be in it were about twice the size they should have been. i changed my oil cooler lines while i was at it, and i installed new motor mounts. the car runs sooth... some of the time. and other parts of the time is like riding a bull. i adjusted the valves... but that didn't seem to help. maybe i miss-adjusted one or something. because it will be smooth like a kitten and then like a bull... I'm going to change the fuel filters again... forgot to buy those. and I'm hoping that helps... my dad just got his injectors rebuilt on his Ford... i might have a set rebuilt for the Mercedes.

anyone have an idea on what it should cost to get a set of injectors rebuilt for my car?

i have a 300D that i was going to give to my sister... i'm thinking about pulling the injectors off that car and getting them rebuilt for my car and then having my old injectors rebuilt for her.. that way my car is never down since her car never moves. (more problem then i can count) if there any problems having the injectors off a 617N/A put on a 617 Turbo?

Thanks for all the help!

Nik
__________________
1983 Toyota Tercel 4WD Wagon - 1984 Mercedes-Benz 300SD 4-Speed(My Car!) 2005 C230 Kompressor 6-Speed Manual
Reply With Quote
  #2  
Old 08-08-2006, 11:28 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,093
I may stand corrected, but I am almost positive that I have read here that the injectors of N/A are not compatible with a Turbo. I believe there is a big difference in pop pressures.

For the difference in idle smoothness, try adjusting/replacing the rack dampener bolt on the rear of the IP. I think there are photos here somewhere if you are unsure of where it is.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page