Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2006, 04:49 PM
Registered User
 
Join Date: Nov 2006
Posts: 12
Does my 300SD shift to soon?

Hey guys, i needed some advice. When I floor my 1984 300SD it only revs to about 3500rpms in 1st gear before shifting, is this normal? In every other gear it revs to about 4600rpms before it shifts. The car feels fine and like it has plenty of power, but for some reason it shifts earily out of 1st. thanks for your help.

Reply With Quote
  #2  
Old 11-17-2006, 06:44 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Sometimes they do this.

The SD does the same thing.

Not much you can do about it short of rebuilding the trans and that is no guarantee of success.

If you need more revs in first, just shift it manually.

A little trick:

Once you shift up to "3" and the trans shifts to second, immediately downshift to "1". It won't downshift but it will hold in second until you shift back to "3" again.

You can control all three shifts to the exact point that you wish using this method.
Reply With Quote
  #3  
Old 11-17-2006, 06:49 PM
PanzerSD's Avatar
Schießenstern
 
Join Date: Jan 2006
Location: Saskatchewan Canada
Posts: 2,351
But manually shifting won't make a flare go away, it'll just flare when it tries to go into that gear...

here's MY SD transmission problem. 50Kmh steady in 4th gear, and I accelerate a little to get to 55 and 4th gear slips and revs like it was in neutral, his the KD switch of do it manually into 3rd and it'll buck into third...
very annoying...
__________________
RIP: 80 300SD
RIP: 79 450SEL
2002 E430 4matic (212,000km)

____________________________
FACEBOOK:
PANZER450
Reply With Quote
  #4  
Old 11-17-2006, 06:55 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Quote:
Originally Posted by Got_The_Benz View Post

here's MY SD transmission problem. 50Kmh steady in 4th gear, and I accelerate a little to get to 55 and 4th gear slips and revs like it was in neutral, his the KD switch of do it manually into 3rd and it'll buck into third...
very annoying...
.........you're on borrowed time.........
Reply With Quote
  #5  
Old 11-17-2006, 06:59 PM
Registered User
 
Join Date: Nov 2006
Posts: 12
Well its a problem that i can deal with and i dont mind it. But do you think its going to get works?
Reply With Quote
  #6  
Old 11-17-2006, 07:08 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Quote:
Originally Posted by audiboi2 View Post
Well its a problem that i can deal with and i dont mind it. But do you think its going to get works?
.........it's most certainly going to get worse........I just cannot predict when that will be...........

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page