Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2006, 09:48 AM
a2t a2t is offline
Registered User
 
Join Date: May 2005
Location: Atlanta, GA
Posts: 941
Bleeding Diesel System

Im trying to purge my 87 300D turbo after frybrid veg oil kit install. I installed the frybrid kit, which requires some changes to the diesel routing as follows :

Diesel in goes straight to in side of main diesel filter (instead of to pre-filter, then lift pump, then intake side of main filter).

From there, it comes out and into a solenoid valve. From that valve it goes into the OEM fuel heater, then lift pump, then IP.

So I unhooked line from heater to lift pump and hooked in a mitivac vacuum pump. Im getting tons of air bubbles – should this ever seal up or will I always get air under normal circumstances? Is there a better way to bleed out fuel system then what Im doing? Can I bleed past either the lift pump or IP, or will that not be possible? I know I have to remove the banjo bolt on the return side of main filter and plug the hole, but I haven’t done that yet. I wonder if that is causing all the air bubbles?

Is it necessary to bleed the return lines back to tank? Or will that just work itself out once engine runs?

Thanks in advance.

__________________
Paul
Benz-less
I need an SDL !
Reply With Quote
  #2  
Old 11-27-2006, 04:42 PM
a2t a2t is offline
Registered User
 
Join Date: May 2005
Location: Atlanta, GA
Posts: 941
__________________
Paul
Benz-less
I need an SDL !
Reply With Quote
  #3  
Old 11-27-2006, 04:44 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,875
You may want to contact Frybrid.
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 280K miles

03 VW Golf TDI 5 speed 400K Miles Engine died

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 400K
Reply With Quote
  #4  
Old 11-28-2006, 10:41 PM
a2t a2t is offline
Registered User
 
Join Date: May 2005
Location: Atlanta, GA
Posts: 941
I am. They dont answer many of my questions.

http://www.frybrid.com/forum/showthread.php?p=46419#post46419
__________________
Paul
Benz-less
I need an SDL !
Reply With Quote
  #5  
Old 11-29-2006, 08:46 AM
Brewer's Avatar
The spice must flow.
 
Join Date: Sep 2006
Location: Milwaukee
Posts: 66
I'd help, but you're always one step ahead of me.

Have you fired it up yet?

(I'm 'hotbox' on Frybrid.com)
__________________
1987 300D - Frybrid - sold
1985 300SD
Reply With Quote
  #6  
Old 12-06-2006, 12:42 PM
a2t a2t is offline
Registered User
 
Join Date: May 2005
Location: Atlanta, GA
Posts: 941
Nope, havent fired it up. Ive got diesel lines bled, just need to ensure WVO lines are vacuum tight, pour in some fuel and also bleed coolant system.

Then I need to reinstall the intake mani (removed to repl glow plugs, then stripped a damn bolt)

Progress is slow at best.

__________________
Paul
Benz-less
I need an SDL !
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page