Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2006, 01:56 PM
Registered User
 
Join Date: Oct 2006
Location: Livingston, TN
Posts: 131
77 300D Cruise Control

Anyone have any experience with the cruise control on the early W123, can on left front wheel well? Think mine has a bad diaphram, any help, thoughts?
Ron
Reply With Quote
  #2  
Old 12-05-2006, 02:50 PM
Registered User
 
Join Date: Feb 2003
Location: Oklahoma
Posts: 1,021
I went through mine a few months back - tested everything and it turned out to be the amplifier. The 'can' should hold a vacuum - pull about 15-20 psi with a mighty vac and see if it holds - you should be able to see it pull and hold the throttle open thru the cruise control cable. If I remember right I had to run 12 volts to the connector - from the battery - to turn the cruise on, and then I pulled the vacuum. It should hold. You can also undo the screws and take a peek at the rubber diaphram - not hard to get to.

Ryan
__________________
RG Newell

1984 300D
1972 250
1986 560SL
1991 300CE
Reply With Quote
  #3  
Old 12-05-2006, 07:20 PM
Registered User
 
Join Date: Oct 2006
Location: Livingston, TN
Posts: 131
Ryan thx
Ron
Reply With Quote
  #4  
Old 12-05-2006, 08:43 PM
Registered User
 
Join Date: Jul 2006
Posts: 46
123 and 107 and 124 and and.....are notorious for failed CRUISE CONTROL......If unless you have big pockets, live without it!
Reply With Quote
  #5  
Old 12-05-2006, 11:29 PM
Registered User
 
Join Date: Jan 2006
Posts: 28
on my 123 the cruise works fine until you roll the window down. then it kicks it out of cruise. What's the deal?
__________________
1980 300d on veggie
Reply With Quote
  #6  
Old 12-05-2006, 11:49 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by cconbalsam View Post
on my 123 the cruise works fine until you roll the window down. then it kicks it out of cruise. What's the deal?
Keep the window up.....

Do these vac. cannister type have a cruise amp? It appears similar to the style on my '79 Chevy PU.
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #7  
Old 12-05-2006, 11:52 PM
Registered User
 
Join Date: Feb 2003
Location: Oklahoma
Posts: 1,021
My cruise works great - I bought a rebuilt amplifier (which I have discovered is usually the problem) from a company in Georgia for a reasonable price and it has worked fine since - link below.

http://www.benz-store.com/index.htm

Ryan
__________________
RG Newell

1984 300D
1972 250
1986 560SL
1991 300CE
Reply With Quote
  #8  
Old 12-05-2006, 11:55 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by rgnprof View Post
My cruise works great - I bought a rebuilt amplifier (which I have discovered is usually the problem) from a company in Georgia for a reasonable price and it has worked fine since - link below.

http://www.benz-store.com/index.htm

Ryan
Thanks for link. You really should put your car type in your signature, so we can tell what you are referring to.
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page