Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-17-2007, 05:05 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
99 E300 Slow shutdown

Last night when turning engine off, RPM's rose from 600 to 700 and then shutdown occured quickly and suddendly as usual. Did same thing today. The rush of fuel is very short, lasting ~1/4 -1/2 second. Am guessing about the 100 rpm increase as the electronics are off as soon as the key is turned off.

No leaks. No CEL.

Shutoff valve and K40 are both 2.5 years old.

Has gotten colder here this week, down to 30 at night. Has felt a little sluggish in the morning which I attributed to the colder weather, now am not so sure.

Am thinking this is shutoff valve related.

Can anyone confirm?

__________________
Terry Allison
N. Calif. & Boca Chica, Panama

09' E320 Bluetec 77k (USA)
09' Hyundai Santa Fe Diesel 48k (S.A.)
Reply With Quote
  #2  
Old 01-17-2007, 05:17 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
Most likely it's the shutoff valve or its o-ring. Check from underneath for any sign of fuel leaking. If it's not leaking, I'd wait till the weather warms up and see what happens.
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
  #3  
Old 01-17-2007, 05:22 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
No leaks as of 2 weeks ago when IM was off and none I could see last night or today.

Am thinking to be more proactive, if a short occurs in the shutoff valve it can take out the ECU.
__________________
Terry Allison
N. Calif. & Boca Chica, Panama

09' E320 Bluetec 77k (USA)
09' Hyundai Santa Fe Diesel 48k (S.A.)
Reply With Quote
  #4  
Old 01-17-2007, 05:23 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Shut-off valve is the most common problem for those symptoms..
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 01-17-2007, 05:32 PM
F18 F18 is offline
Registered User
 
Join Date: Oct 2005
Location: Massachusetts
Posts: 677
Odd! Fuel should be shut off as soon as the electrics are off with the Key in the 0 or off postion. The Shut Off Valve, which is electronic must be defective and not closing right away so its still delivering a slug of fuel to the IP after the key is turned off. 30deg. F should have little or no effect on that engine unless you have bad glow plugs and fuel line leaks, or clogged fuel filters which would be aggrivated by the colder temps.
I don't know if there is a trouble code associated with a defective Shut Off Valve. May be someone else can chime in........
__________________
FRED

Daily Driver: 98 E300TD 199K
Hobby Car: 69 Austin Mini
Past Diesels: 84 300SD, 312K
87 300SDL, 251K
94 Chev. K-1500 6.5Ltr.TD, 373K
Reply With Quote
  #6  
Old 01-17-2007, 06:15 PM
Registered User
 
Join Date: Jul 2004
Location: Annapolis, Md.
Posts: 556
Same thing happened to me today. Quite a delayed shut down. Afterward the CEL came on and the code read for the shut off valve. I cleared it and all is fine but I wonder. My car has not been starting as snappy. Maybe the valve is slow to open and close.

I am sure the veg does not help either. I have been thinking of getting a 603 mechanical pump for my 99 maybe from Myna diesel. I know it fits, Mauri has showed us that. That would take care of it. I got 32mpg with my 87 with the full load turned up. I never get that with this car and its electronic pump. I am sure the chip does not help that but even with light throttle doing 75-80mph I get no more than 30mpg if I am lucky.

Then how will the electronic trans behave without the engine computer?? I bet it will not be happy and how do you get around it. Does a 97 E300 Diesel have the same 5spd as the 98&99s? Maybe just use that computer??? That would probably also mean a keyed ignition with vacuum lines.

Probably not the easiest solution for the shut off valve issue. Are there any hybrid euro pumps that offer a different solution? I just have never been fond of the plastic lines snaking all over the place just to use an electronic shut off valve.
__________________
-disav

99 E300 TURBODIESEL Astral Silver 282K - AMG brakes, suspension, monoblocks, speedo & interior - Full Load Maxed on IP by custom Speed Tuning USA Chip - T3/T4 Garrett - EGR/MAF delete
98 E300 TURBODIESEL Alexandrite Green on black leather 289K
95 E300 DIESEL Green Queen 267K SOLD
84 300D 216k SOLD
87 300D 299K #22 head - intercooler - full load adj. - 8sec 0-60mph - SOLD
76 300D 214K SOLD
Reply With Quote
  #7  
Old 01-17-2007, 06:26 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Quote:
Originally Posted by F18 View Post
30deg. F should have little or no effect on that engine ........
I live in Calif....It's only gotten up to 55f or so during the daytime this week. A very miserable cold spell. Lots of people have actually had to put on long pants.

Thanks for the replies, suspect I will end up with another new shutoff valve shortly.
__________________
Terry Allison
N. Calif. & Boca Chica, Panama

09' E320 Bluetec 77k (USA)
09' Hyundai Santa Fe Diesel 48k (S.A.)
Reply With Quote
  #8  
Old 01-17-2007, 06:32 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Quote:
Originally Posted by mdisav View Post
Same thing happened to me today. Quite a delayed shut down. Afterward the CEL came on and the code read for the shut off valve
Which code did you get?

With yours running on Veg I might wait a week for some warmer weather before deciding there is a problem.

I see NO way you could get rid of the ECU; much to integrated.

>>>>>EDIT: 1 week later using a very bight flashlight found slight staining on the side and bottom of shutoff valve. VERY minor leak. Repalced oring with viton o-ring and symptoms were gone.
__________________
Terry Allison
N. Calif. & Boca Chica, Panama

09' E320 Bluetec 77k (USA)
09' Hyundai Santa Fe Diesel 48k (S.A.)

Last edited by TMAllison; 03-25-2007 at 09:55 PM.
Reply With Quote
  #9  
Old 01-17-2007, 06:40 PM
Registered User
 
Join Date: Jul 2004
Location: Annapolis, Md.
Posts: 556
I believe it was 215 if I am remembering correctly. I hear you about the ecu, just a bunch of thoughts in my head...
__________________
-disav

99 E300 TURBODIESEL Astral Silver 282K - AMG brakes, suspension, monoblocks, speedo & interior - Full Load Maxed on IP by custom Speed Tuning USA Chip - T3/T4 Garrett - EGR/MAF delete
98 E300 TURBODIESEL Alexandrite Green on black leather 289K
95 E300 DIESEL Green Queen 267K SOLD
84 300D 216k SOLD
87 300D 299K #22 head - intercooler - full load adj. - 8sec 0-60mph - SOLD
76 300D 214K SOLD
Reply With Quote
  #10  
Old 01-18-2007, 08:21 AM
shoe's Avatar
Senior Member
 
Join Date: Jun 2000
Location: Baton Rouge, LA.
Posts: 583
I doubt it is temp related I live in south Louisiana and have had the same problem on my 96 E300 before at near 80 degrees outside. Not only that your under hood temp after running is much warmer than outside temp so fuel should be at least as warm as the engine bay. Mine is still intermittent so I have not changed the shut off valve yet but plan to soon.

__________________
Keith Schuster
2006 E350 98K miles
2013 Ford Explorer 15K miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page