Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 02-12-2007, 03:54 AM
Registered User
 
Join Date: Jan 2007
Location: Fresno, CA
Posts: 193
I just bought a 96 E300, I am going to check the spring perches soon, I was wondering what I should reseal the coating with when I peal it off? Hopefully it is something I can just pick up a local parts store. I am going to cross my fingers that they are ok. 115,000 and its lived in California its life, but from what I have read that may not matter.
__________________
1999 E300 TD 190,000
1996 Passat TDI 225,000-sold
1996 E300 120,000-sold
1998 Jetta TDI 186,000 -sold
1983 Chev Suburban C20 6.2-sold
Reply With Quote
  #17  
Old 02-12-2007, 06:46 AM
ncof300d
Guest
 
Posts: n/a
Quote:
Originally Posted by DieselAddict View Post
According to one poster here there is a service bulletin regarding this issue in Canada but not in the US the last time my dealer checked and I haven't seen anyone here find one either. I think it will take at least a few publicized deaths before MBUSA gets off its ass and issues a recall.
Then my question is if there is no service bulletin then why would a dealership inspect this item? I asked the service manager over a year ago about this and he told me that he had never heard of such a problem. Granted in my dealings with this person on prior issues I take his word with a few pinches of salt.
Reply With Quote
  #18  
Old 02-12-2007, 01:35 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
Quote:
Originally Posted by aklim View Post
Maybe I will have them clean off the other one and reseal it so we know it is good?
That's what I would do.

Quote:
Originally Posted by dauber View Post
I just bought a 96 E300, I am going to check the spring perches soon, I was wondering what I should reseal the coating with when I peal it off? Hopefully it is something I can just pick up a local parts store. I am going to cross my fingers that they are ok. 115,000 and its lived in California its life, but from what I have read that may not matter.
You can buy undercoating in a spray can in pretty much any auto part store. However, don't put undercoating directly on a rusted surface as it won't adhere. POR15 or a similar product would be a much better choice in that case. POR15 can also adhere to a non-rusted surface if it's properly prepped. That's probably what I would use to reseal the perch if it's still good.

Quote:
Originally Posted by ncof300d
Then my question is if there is no service bulletin then why would a dealership inspect this item? I asked the service manager over a year ago about this and he told me that he had never heard of such a problem. Granted in my dealings with this person on prior issues I take his word with a few pinches of salt.
My dealership told me the same thing. At first they were in complete denial that such a problem could even exist. A bit later they just said they'd never heard of this problem but they agreed to look at my car. Since I had already peeled off the undercoating, they could clearly see the problem, but they still didn't want to do anything about it. I think it took like a week or so before they agreed to pay for half of the expense of repairing this problem as a "good-will gesture". Grudgingly I accepted after unsuccessfully pushing them to cover everything since it is a safety defect and bad design with which they disagreed.

I think one day this issue will bite DC hard because someone's going to get injured or killed and prosecutors will show that DC had prior knowledge of this problem and failed to issue a recall.
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL

Last edited by DieselAddict; 02-12-2007 at 01:41 PM.
Reply With Quote
  #19  
Old 02-16-2007, 07:32 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
BTW here's a part of that Canadian (I think) technical service bulletin on this issue.
Attached Thumbnails
210 Owners. Check your Spring Perch-mbtechbull.jpg  
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
  #20  
Old 03-08-2007, 10:07 PM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Thumbs up

MBUSA called my dealership and they are paying for half the repair of the perch.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
  #21  
Old 03-09-2007, 07:05 AM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by aklim View Post
MBUSA called my dealership and they are paying for half the repair of the perch.
What did it land up costing to have it done?
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #22  
Old 03-09-2007, 07:15 AM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Quote:
Originally Posted by nhdoc View Post
What did it land up costing to have it done?
About $600 for parts and labor.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
  #23  
Old 03-09-2007, 07:40 AM
Registered User
 
Join Date: Jul 2001
Location: Western Michigan
Posts: 1,080
My 1997 E320 is still at the dealer picked body shop to have both sides done. I brought there on Tuesday (it is Friday now).

The Canadian recall is for 1996 - 2000 W210 except 4Matic. That does not mean others won't have this problem.

MBUSA is only paying 50% for my repair. The body shop cost is about $1400 for both sides. A front end alignment is needed after the repair for another $150 - 200. So I am looking to pay for about $800. They give me a lowner to drive for now.

I am not a "good" customer because I do not go there for service or repair. They sometimes pay 100% for "good" customers. Also I heard that if they completely fail (spring pops out), MBUSA also pays 100%.

They looked OK but once I peeled the sealer, there was a lot of surface rust at the time. The passenger side was much worse in my case.

I strongly recommend to have both sides done. They will eventually fail. I also believe MBUSA eventually will have to recall in the USA. At that time, we can ask the 50% back.

Last edited by loubapache; 03-09-2007 at 07:46 AM.
Reply With Quote
  #24  
Old 03-09-2007, 07:50 AM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by aklim View Post
About $600 for parts and labor.
I assume that was for one side only?
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #25  
Old 03-09-2007, 08:15 AM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Quote:
Originally Posted by nhdoc View Post
I assume that was for one side only?
Yes, the other side was fine.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
  #26  
Old 03-09-2007, 11:31 AM
deuce's Avatar
Registered User
 
Join Date: Dec 2001
Location: Greensboro, NC
Posts: 186
I haven't visually checked but for a few years now there's been an audible "Clunk" from the driver's side wheel area when I make a left turn onto a downhill road on my daily trip home from work. My tech has looked all over the suspension system and can't find anything. Is it possible that the Spring Perch issue could be causing that? I've also got the "60 MPH" vibration and have had the lower control arm bushings replaced but it didn't fix it. It does lessen significantly after driving the car for a while but I've got a checking problem on the front tires. Don't know if any of this is related but figured I'd put all the symptoms out there.

Thanks,
__________________
Deuce
'11 ML350 41K
'06 Honda Odyssey 110K (Kid's Taxi)
'02 E320 151K (Sold)
'96 E300D (RIP Riggo - 12/16/2010) 198K
'03 Honda Odyssey 34K (Sold)
'95 E300D 145K (Sold)
'01 Mazda Tribute 19K (Sold)
Reply With Quote
  #27  
Old 03-09-2007, 11:43 AM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
I don't think so. Mine never had those issues and was tearing. check the perches and see if they are tearing off.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page