Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2007, 03:56 PM
firstdiesel's Avatar
Registered User
 
Join Date: Sep 2002
Location: South Florida
Posts: 243
Nailing just started

'80 300TD

Well I have just spent about half a day reading posts and only one comes close, but alas not quite.

I have been driving this car for about 4 years and the strongest thing has been the engine. No noise, nailing, knocking........until NOW .

I commute about 145 miles to work about 10-12 times a month. You read it right, almost 300 miles round trip in 24hrs. My engine has run smooth the whole time. As of late though I have been getting what I would describe as "nailing" at cruise speeds only. Yup, thats right at cruise speeds. Starts fine, I live in Florida so cold temp is really not a problem. No major smoke on start-up and seems to idle without any nailing. But, after accelerating with the cruise control on at hwy speed (70-75 mph) I get random nailing. Sometimes once in a while and then for about 5 seconds and then gone again for some of the trip and then back a little louder and there is no real rhyme or reason. When I exit the hwy and stop at the light at the end of the ramp, it idles pretty rough (car shakes more than out of sync idle though).

Around town I do not get any of these symptoms. I two can diesel purged her and followed with a Lubro Molly fuel additive chaser. Nothing changed. I changed both fuel filters after the purge and used different gas stations just to rule out the fuel contamination thing.

I have dumped more money than I had planned (yeah, I know, welcome to the club) to keep this running. I have done the work myself and all has gone well and then this rears its ugly head! I am hoping this is an injector thing and not a knocking problem. If it is a knocking thing there will be a lot of new parts for sale on ebay really soon. The exterior of the car has a lot to be desired and until now I had a real strong running car. Well, I take that back the car seems to run just fine. No real lack of power, 23-24mpg hwy, little or no smoke, but eats a little too much oil for my taste.

Anyway, she'll be making the trip on Thursday again so any input would be helpful.

__________________
1980 300TD, SOLD
1984 300TD, 275K
1999 C230 K Black & Tan
2013 C250 Black
You might faint from the fight, but you're gonna find it. Every challenge could have paradise behind it. -John Popper-
Reply With Quote
  #2  
Old 03-12-2007, 04:07 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Probably an injector. You haven't been running this car on any alternative fuels lately have you?

Pull the injectors and take them to a fuel injection shop. They will likely test them for free and let you know if they need any work.

Have you tried an Italian tune up?
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #3  
Old 03-12-2007, 07:20 PM
firstdiesel's Avatar
Registered User
 
Join Date: Sep 2002
Location: South Florida
Posts: 243
Italian tune up? You have my attention....go on.

This car has never been run on alternative fuels...GASP....OH MY....OH THE HUMANITY!!....Yes, I know. I just haven't found the right WVO source and I am yet to find ANY biodiesel in Palm Beach or Broward county area (Ft. Lauderdale). All of the fuel system is stock and I would imagine original.
__________________
1980 300TD, SOLD
1984 300TD, 275K
1999 C230 K Black & Tan
2013 C250 Black
You might faint from the fight, but you're gonna find it. Every challenge could have paradise behind it. -John Popper-
Reply With Quote
  #4  
Old 03-12-2007, 07:24 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Just checking...somebody had a similar problem after running WVO from the main tank.

The Italian tune up is simple. Just drive the car hard. It will blow out all of the carbon and crud that has been accumulating. A search on "Italian tune up" will provide more information than you can shake a stick at.
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #5  
Old 03-12-2007, 07:42 PM
firstdiesel's Avatar
Registered User
 
Join Date: Sep 2002
Location: South Florida
Posts: 243
I will be checkin' it out. I'll call around and get a shop to test them. Thanks for the quick response.
__________________
1980 300TD, SOLD
1984 300TD, 275K
1999 C230 K Black & Tan
2013 C250 Black
You might faint from the fight, but you're gonna find it. Every challenge could have paradise behind it. -John Popper-
Reply With Quote
  #6  
Old 03-12-2007, 08:10 PM
d.delano's Avatar
Dönerkebap
 
Join Date: May 2004
Location: DC
Posts: 1,466
I contend that there is something about ULSD that my car just does not like. No leaks at IP, had some leaking fuel hose and returns but changed 'em all out. Swapped two injectors out. Replaced tank screen. Fuel fiters, yada yada. I did it all. Car just doesn't go like butta as before. I mean the car was fast. Now it ain't. This change occurred about a tank after ULSD hit the scene. I can hear an airy kind of tapping noise in time with RPM. I used to have another car that made the same-ish sound due to an exhaust manifold that had a hole in it. ? Maybe its coincidence and I need a new turbo mount kit. Boost press is down about a pound or so. Oh well- I need new turbo seals anyway. I think I'll rebuild that spare turbo I have lying around and go to town.
__________________
'02 BMW 325i
'85 300D 450k
'93 190E 2.6 170k(killed by tree)
'08 Ducati Hypermotard 1100S 6k
'06 Ducati S2R800 14k(sold)
Reply With Quote
  #7  
Old 03-12-2007, 09:04 PM
firstdiesel's Avatar
Registered User
 
Join Date: Sep 2002
Location: South Florida
Posts: 243
Yes, I understand, but I don't even have a turbo so I will go with the injectors and keep my fingers crossed. Talk about eerie, I drive the thing across Alligator Alley in the middle of the night; once at 3 am and then work and then back starting at midnight. I hear all kinds of spooky sounds coming from the engine compartment with no land in sight! Thats why I asked, I could just be paranoid!
__________________
1980 300TD, SOLD
1984 300TD, 275K
1999 C230 K Black & Tan
2013 C250 Black
You might faint from the fight, but you're gonna find it. Every challenge could have paradise behind it. -John Popper-
Reply With Quote
  #8  
Old 03-12-2007, 09:06 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Try giving it a good hard run first.

__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page