Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2007, 10:07 PM
Registered User
 
Join Date: Aug 2006
Posts: 185
Transmission shifter problems

I have a 1984 300sd. The transmission shifter will not let me shift to reverse or park. This is what I have done so far. Took the linkage loose and veryfied that the linkage was not binding. I worked the transmission arm back and forth several times and the shifter worked several times, but is binding again. I do not want to apply too much pressure. Can I see and repair the problem with removing the pan? Thoughts and suggestions welcome. Thanks in advance. Jack Avant
Reply With Quote
  #2  
Old 06-02-2007, 10:11 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Are the nylon shift bushings still in place at both ends of the rod?

That's a typical failure at this age. I recently did them on the SD. The one at the bottom of the shifter was no longer in existence.
Reply With Quote
  #3  
Old 06-02-2007, 10:41 PM
Registered User
 
Join Date: Aug 2006
Posts: 185
Quote:
Originally Posted by Brian Carlton View Post
Are the nylon shift bushings still in place at both ends of the rod?

That's a typical failure at this age. I recently did them on the SD. The one at the bottom of the shifter was no longer in existence.
From what I could see the bushings felt and looked good. When I took the shifter loose it still took a lot of working back aand forth to get it to move before I hooked the shifter back up.
Reply With Quote
  #4  
Old 06-02-2007, 10:44 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Quote:
Originally Posted by jack avant View Post
From what I could see the bushings felt and looked good. When I took the shifter loose it still took a lot of working back aand forth to get it to move before I hooked the shifter back up.
So, your problem is in the shifter.........not the transmission.........and not the linkage.

The shifter, itself, has a set of nylon bushings that allow it to move.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page