Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2007, 05:40 PM
Registered User
 
Join Date: May 2007
Posts: 36
1980 300d "off" pushbuttons not working

I have finally gotten my a/c situation in order. But, pushbuttons in the "off" position does not go off. It continues to blow on low setting. All other buttons work fine. Heating and cooling work fine. I have vertical buttons. Any idea what could remedy this problem. I can buy the new pushbuttons for $140 at Dealer. Just not sure this will fix it. Not returnable.

The other thing is that when I start the car the a/c will not go on without giving a little throttle. Push the footfeed and a/c then goes on. Wierd. I guess vacuum increases enough to activate the system.

Paul

Reply With Quote
  #2  
Old 06-22-2007, 05:44 PM
winmutt's Avatar
85 300D 4spd+tow+h4
 
Join Date: Apr 2006
Location: Atl Gawga
Posts: 9,332
Quote:
Originally Posted by lg4mat View Post
I have finally gotten my a/c situation in order. But, pushbuttons in the "off" position does not go off. It continues to blow on low setting. All other buttons work fine. Heating and cooling work fine. I have vertical buttons. Any idea what could remedy this problem. I can buy the new pushbuttons for $140 at Dealer. Just not sure this will fix it. Not returnable.

The other thing is that when I start the car the a/c will not go on without giving a little throttle. Push the footfeed and a/c then goes on. Wierd. I guess vacuum increases enough to activate the system.

Paul
Yes sounds like you still have vacuum issues run through the system again.
__________________
http://superturbodiesel.com/images/sig.04.10.jpg
1987 300D Sturmmachine
1991 300D Nearly Perfect
1994 E320 Cabriolet
1995 E320 Touring
2001 Eurovan FOR SALE
1985 300D car, sold and missed.
OBK #42
Reply With Quote
  #3  
Old 06-22-2007, 07:09 PM
Registered User
 
Join Date: May 2007
Posts: 36
Vacuum

When I mityvac the green line at engine I can not hold vac at all.
Is this right.
WHat vacuum # should I be getting at the green line?

I tried another 300d car and got same results. Other car works fine. a/c wise.

No matter how much vacuum I apply to the (green) climate control line on engine side I can't get the "off" button to turn system off. Thats what confusing me.

I plugged ignition and door lock lines to pull only on climate line with mityvac.
Reply With Quote
  #4  
Old 06-24-2007, 10:17 PM
babymog's Avatar
Loose Cannon - No Balls
 
Join Date: Jan 2006
Location: Northeast Indiana
Posts: 10,767
Not the same CCU, but my 124 did the same thing, fan would run in OFF position, replaced CCU and all was solved. Replaced seized aux. pump also (after CCU replacement solved the fan issue).
__________________

Gone to the dark side

- Jeff
Reply With Quote
  #5  
Old 06-24-2007, 10:55 PM
Abandon the Roads!
 
Join Date: Feb 2007
Location: Texas
Posts: 283
Vacuum only determines which vents are open. It has nothing to do with the A/C clutch engaging or the blower control.

Sounds like you have a bad pushbutton unit for the off problem.
As for the A/C compressor clutch not engaging, I'm not entirely familiar with the klima relay, but I'm pretty sure if won't engage until the engine gets above a certain temperature or something like that, the idea being to keep the engine from trying to turn the compressor and stalling out.
__________________
1984 300DT turbo 138k mi

Still hauling me to school and back.

Handy Site:
http://www.dieselgiant.com/
Reply With Quote
  #6  
Old 06-25-2007, 09:54 AM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,389
all the off button does is disengage the other buttons. it's purely mechanical. you may be able to dissassemble it and repair the problem, but a new unit may be needed.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #7  
Old 06-25-2007, 01:31 PM
Abandon the Roads!
 
Join Date: Feb 2007
Location: Texas
Posts: 283
Heh, incidentally, my off and defrost buttons don't disengage whatever is pressed, so I can't turn off my ACC either. At some point I will probably take out the pushbutton unit to test it.

__________________
1984 300DT turbo 138k mi

Still hauling me to school and back.

Handy Site:
http://www.dieselgiant.com/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page