Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-06-2007, 04:24 PM
oldiesel's Avatar
Registered User
 
Join Date: May 2007
Location: florida
Posts: 677
Thumbs up 143 amp alt in 300d 2.5

Thanks to information i received here i was able to get and install a 143amp alternator on my 91 300d 2.5. now even with my headlights on and the a/c on high at idle it never goes below 13.6 measured at the cigar lighter which seems to be about .2 below the batt voltage with different meters.before the change, in city traffic it would get down to 11.5 or so with only the a/c on.
The old alternator was a 70amp made by Iskra in Slovenia and was not getting the job done and was putting out a bit over 2ac volts,and causing most of the warning lights along the bottom of the instrument panel to be lit at times.The new alternator shows only .095mv ac and all lights are out with the engine running. Don
__________________
Red Green "This is only temporary,Unless it works!"

97 E300D 157000 miles
87 300TD ?141k? miles
Reply With Quote
  #2  
Old 09-06-2007, 04:53 PM
LUVMBDiesels's Avatar
Dead on balls accurate...
 
Join Date: Aug 2006
Location: Red Lion,Pa
Posts: 2,207
Great fix!

I wonder why MB put these undersized alternators in the diesel cars...

I just replaced mine with a 135Amp from a Saab. Now even with the defogger, headlights, windshield wipers, rear defogger, and radio on, everything works as it should. Before I had to kill the radio and switch between front and rear defogger or the "ALT" light would come on...
And that was with a new voltage regulator!
__________________
"I have no convictions ... I blow with the wind, and the prevailing wind happens to be from Vichy"

Current
Monika '74 450 SL
BrownHilda '79 280SL
FoxyCleopatra '99 Chevy Suburban
Scarlett 2014 Jeep Cherokee
Krystal 2004 Volvo S60
Gone
'74 Jeep CJ5
'97 Jeep ZJ Laredo
Rudolf 86 300SDL
Bruno '81 300SD
Fritzi '84 BMW
'92 Subaru
'96 Impala SS
'71 Buick GS conv
'67 GTO conv
'63 Corvair conv
'57 Nomad
Reply With Quote
  #3  
Old 09-06-2007, 08:46 PM
patbob's Avatar
Its a Whatsit
 
Join Date: Oct 2006
Location: Portland, OR
Posts: 837
Quote:
Originally Posted by oldiesel View Post
The old alternator was a 70amp made by Iskra in Slovenia and was not getting the job done and was putting out a bit over 2ac volts,and causing most of the warning lights along the bottom of the instrument panel to be lit at times.The new alternator shows only .095mv ac and all lights are out with the engine running.
With AC noise that large, it sounds like a some of the diodes were going and making the problem worse than it otherwise might have been. A better alternator, fix of intermittant electrical wierdness and and upgrade all in one chore.. doesn't get much better than that
__________________
'83 300DTurbo http://badges.fuelly.com/images/smallsig-us/318559.png

Broadband: more lies faster.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page