Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 11-27-2007, 10:42 PM
thesst's Avatar
Registered User
 
Join Date: Nov 2007
Location: Ellensburg, WA
Posts: 470
Haha yes Shawn... I was thinking of tung oil. lol don't shop for light bulbs and write about oil at the same time!

Actually, though, my cable has not failed (works perfectly) but SOMETHING in the instrument cluster is very very noisy (sounds like a hornet's nest when at high speeds), which is quite irritating. I assumed it was the speedo/odo cable(s).
__________________
'79 300SD
'82 Chevy Chevette diesel
Reply With Quote
  #17  
Old 11-27-2007, 11:51 PM
PanzerSD's Avatar
Schießenstern
 
Join Date: Jan 2006
Location: Saskatchewan Canada
Posts: 2,351
Quote:
Originally Posted by 85 DSEL View Post
Someone once told me that the proper lubricant for a speedo cable is graphite - same stuff used inside lock cylinders.

Anybody else hear this?
yes, that makes sense....since it is isn't effected by dust or tempurature and if moistend will dry.
__________________
RIP: 80 300SD
RIP: 79 450SEL
2002 E430 4matic (212,000km)

____________________________
FACEBOOK:
PANZER450
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page