Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-14-2007, 11:44 AM
Registered User
 
Join Date: Oct 2006
Posts: 10
300 SD electrical issues

Hello,

I havent been on the forum recently but I have a nagging issue that is starting to become incovenient.

I purchased a 1992 300 SD mercedes 2 years ago and it has gone 12,000 miles so far with minimal problems. When I got the car, I knew about the faulty instument cluster.

When I start the car, the cluster works only 50% of the time. Once the car starts, I can drive it for hours without problems.

My question is how long can I go without having to fix the instrument cluster and where can it be rebuilt since a new cluster is over $1000 dollars and the dealer. I live in Salt Lake City. Does anyone know of any good independent mercedes shops.

Chinu
Reply With Quote
  #2  
Old 11-27-2007, 11:33 PM
Registered User
 
Join Date: Oct 2006
Posts: 10
Hello,

Took it to a independent MB mechanic who stated that I need a new mother board. Sent it to ProGrama in Florida to have it rebuilt. Will be in the shop for a week!


Chinu
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page