Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-21-2007, 05:07 PM
240Demon's Avatar
Oo{=|=}oO
 
Join Date: Jun 2003
Location: Oregon
Posts: 331
Hvac

So my new $100 beauty has a number of problems...but the one that I can't figure out is this...


The automatic climate control works...but only when the key is on and the engine isn't...as soon as I start the car, the system quits working completely.

Since I used to have a 240D, I am not used to the whole auto climate dealy...so could some of you 300 guys enlighten me?!
__________________
Nick
*****
1987 Audi 4000 quattro wer:
1987 300SDL
2002 Sprinter 2500 140" High Roof :
1966 Beetle...project in progress
Reply With Quote
  #2  
Old 11-21-2007, 05:14 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Is your ignition switch in good shape? Sounds like the power to the klima is getting cut off after the startup movement of the ignition switch....does everything else work with the engine started?


Question: Why did you sell your manual 240d?
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #3  
Old 11-21-2007, 05:18 PM
240Demon's Avatar
Oo{=|=}oO
 
Join Date: Jun 2003
Location: Oregon
Posts: 331
Quote:
Originally Posted by pawoSD View Post


Question: Why did you sell your manual 240d?
It needed an engine rebuild and my dad didn't wanna pay to do it...as it was in his name...so I wasn't going to pay for the parts...and I was extremely excited about getting my Subaru (which is a great car...lots of fun)...but I miss the reliability and mileage of the 240D...

But now I have this ****tastic 300...so all is well again

(if I can get the HVAC working...it's starting to get cold!)
__________________
Nick
*****
1987 Audi 4000 quattro wer:
1987 300SDL
2002 Sprinter 2500 140" High Roof :
1966 Beetle...project in progress
Reply With Quote
  #4  
Old 11-21-2007, 05:49 PM
Craig
Guest
 
Posts: n/a
Quote:
Originally Posted by pawoSD View Post
Is your ignition switch in good shape? Sounds like the power to the klima is getting cut off after the startup movement of the ignition switch....does everything else work with the engine started?
There's no klima in the 83, but I would suspect the ignition switch. I had to wiggle my old switch to get the climate control to work sometimes. Replacing the electrical part of the switch fixed it.
Reply With Quote
  #5  
Old 11-21-2007, 06:06 PM
240Demon's Avatar
Oo{=|=}oO
 
Join Date: Jun 2003
Location: Oregon
Posts: 331
Quote:
Originally Posted by Craig View Post
There's no klima in the 83, but I would suspect the ignition switch. I had to wiggle my old switch to get the climate control to work sometimes. Replacing the electrical part of the switch fixed it.
Thanks man!


I shall be visiting the junkyard!
__________________
Nick
*****
1987 Audi 4000 quattro wer:
1987 300SDL
2002 Sprinter 2500 140" High Roof :
1966 Beetle...project in progress
Reply With Quote
  #7  
Old 11-21-2007, 06:26 PM
Registered User
 
Join Date: Apr 2003
Location: Phoenix Arizona. Ex Durban R.S.A.
Posts: 3,002
Quote:
Originally Posted by Craig View Post
I had to wiggle my old switch to get the climate control to work sometimes. Replacing the electrical part of the switch fixed it.
Sounds like a similar problem one of my brothers cars had. An 84 200. No a/c, just a blower fan. you would start the car and then have to just very slightly turn the key probably about 1mm anti-clockwise to get the fan to come on. Seems like these ignition switches can wear slightly where the circuit for the blower is, which is likely the same circuit for the climate control in the US spec cars.

- Peter.
__________________
81 240D stick. 316000 miles at purchase. 339000 now
2000 GMC Sonoma
Formerly...
2002 Kia Rio. Worst crap on four wheels
1981 240D 4spd stick. 389000 miles. Deceased Jan 08
1984 123 200
1979 116 280S
1972 Cadillac Sedan DeVille
1971 108 280S
Reply With Quote
  #8  
Old 11-21-2007, 06:27 PM
Craig
Guest
 
Posts: n/a
Quote:
Originally Posted by pj67coll View Post
Sounds like a similar problem one of my brothers cars had. An 84 200. No a/c, just a blower fan. you would start the car and then have to just very slightly turn the key probably about 1mm anti-clockwise to get the fan to come on. Seems like these ignition switches can wear slightly where the circuit for the blower is, which is likely the same circuit for the climate control in the US spec cars.

- Peter.
Exactly how mine worked.
Reply With Quote
  #9  
Old 11-21-2007, 06:57 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
I have had problems with my klima turning off randomly and such for a while too....perhaps I will check this out on mine as well....
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #10  
Old 11-23-2007, 08:22 PM
240Demon's Avatar
Oo{=|=}oO
 
Join Date: Jun 2003
Location: Oregon
Posts: 331
Well...I went out and started the car today, and then turned the key back slightly...

and...the HVAC started working!!


So I am ordering a new switch (found one for $8.78 new)


I went and drove the car too...


and the cruise control works...
__________________
Nick
*****
1987 Audi 4000 quattro wer:
1987 300SDL
2002 Sprinter 2500 140" High Roof :
1966 Beetle...project in progress
Reply With Quote
  #11  
Old 11-24-2007, 01:45 AM
Registered User
 
Join Date: Apr 2003
Location: Phoenix Arizona. Ex Durban R.S.A.
Posts: 3,002
Cool! Nice to know some things are simple fixes.

- Peter.
__________________
81 240D stick. 316000 miles at purchase. 339000 now
2000 GMC Sonoma
Formerly...
2002 Kia Rio. Worst crap on four wheels
1981 240D 4spd stick. 389000 miles. Deceased Jan 08
1984 123 200
1979 116 280S
1972 Cadillac Sedan DeVille
1971 108 280S
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page