Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 12-05-2007, 02:15 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,353
I was just curious. Not looking to install one myself right now.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #17  
Old 12-05-2007, 02:33 PM
Craig
Guest
 
Posts: n/a
Quote:
Originally Posted by kerry View Post
I was just curious. Not looking to install one myself right now.
I also have one installed in my 82. It's a very good deal if your relay goes bad.
Reply With Quote
  #18  
Old 12-05-2007, 02:51 PM
Registered User
 
Join Date: Sep 2007
Location: Redmond, WA
Posts: 622
I started my car with no GPs at all for about 2 months...never had much of a problem....ymmv, though.
__________________
1983 Mercedes-Benz 240D
Automatic, A/C, Power Sunroof, Power Right Side Mirror
231K Miles FOR SALE MAKE OFFER
Reply With Quote
  #19  
Old 12-05-2007, 03:08 PM
rivermasternc's Avatar
J. Scott Moncrief
 
Join Date: Feb 2003
Location: Burnsville, NC
Posts: 144
Quote:
Originally Posted by jkoebel View Post
I started my car with no GPs at all for about 2 months...never had much of a problem....ymmv, though.
Seems like you would have severe compression loss.

I have apparently been starting my truck for about 9 months now with no power to the GP's. Frustrating, given that I advised the Ford Stealership that the pre-glow system needed checking as I was having starting problems at around 40F and below. The word back was "no problems found". Funny, took me all of 10 minutes to ohm out the 8 plugs (all good) and discover no voltage on the back side of the GP relay when switched on, a commom problem with the 7.3L. New relay arrives tomorrow.
__________________
https://goo.gl/photos/J8ZUVvAYiYqLxbD18

1989 560SL 111Kmi
2007 E550 4Matic 157 Kmi
2000 F250SD 7.3l, 1996 Explorer Ltd 5.0l
1965 VW Beetle Deluxe 115 Kmi
=========================
Previous MB:
1983 240D Euro Manual 144 Kmi
1983 300SD 495 Kmi
1986 190D 2.5 100 Kmi
1986 300SDL 202 Kmi
1991 300D 2.5 Turbo 91 Kmi
1998 E320S4 (4-matic wagon) 140 Kmi
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page