Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-26-2008, 02:58 PM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Photos of My 300SD

I finally got a chance to take some photos of the 300SD I bought in November. Here they are:








__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #2  
Old 01-26-2008, 03:07 PM
turbobenz's Avatar
Registered User
 
Join Date: Nov 2007
Location: Cameron Park CA
Posts: 1,869
Thats beautiful. I never liked the w116 till now
__________________
1981 300SD 512k OM603


Reply With Quote
  #3  
Old 01-26-2008, 03:15 PM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Thanks. It was a one owner car until I got it, all stock and original. The PO was a MBCA member from Pittsburgh and had the car rust-proofed when new which apparently worked as it was virtually rust free. I replaced his carpeted mats with new ones as they were really ratty but the rest of the interior is pristine. The headliner is perfect and I was really happy to find one with a sunroof. I like the look of the sunroof cover too.

The mechanics of it are great...started OK today and it was in the 20's when I took it out of its storage garage. I had to fix a few minor things but nothing too serious.
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #4  
Old 01-26-2008, 03:22 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,323
Beautiful car! I don't think I've ever seen a W116 in such good condition! Wshew.
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 90k - mine - (OC-91,200)
'17 Metris(VITO!) - 18k - wifes (OC-25k)
'01 E320 Wagon - 161k - mine (OC-165,000)
'01 E320 - 180k - dad's (OC-182,500)
'07 E350 Wagon - 134k - dad's (OC-139,500)
'01 SL500 - 56k - dad's (OC-59,000)
'16 E400 4matic Sedan - 81k - Brothers (OC-88,000)
Reply With Quote
  #5  
Old 01-26-2008, 03:49 PM
Registered User
 
Join Date: Nov 2007
Location: Cinti.
Posts: 53
Very nice. I love the W116. It's my favorite car. It think it is the extra chrome running just above the bumpers that does it for me!!
__________________
1999 E300 Turbodiesel
179,000 Miles
Reply With Quote
  #6  
Old 01-26-2008, 03:57 PM
TheDon's Avatar
Ghost of Diesels Past
 
Join Date: Oct 2005
Posts: 13,217
the chrome wheel arch trim gaaaa

but it looks great..

a Becker Mexico.. nice
Reply With Quote
  #7  
Old 01-26-2008, 03:57 PM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by imagesinthewind View Post
Nice, it's exactly like mine!

Can I add a photo of mine to your thread?
Sure, be my guest!
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #8  
Old 01-26-2008, 04:01 PM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by TheDon View Post
the chrome wheel arch trim isn't doing it for me..
The PO claims the car always had those arch covers...I don't think so unless it was something the dealers installed after the cars left the factory which is certainly possible, just like pinstriping which was routinely done at the dealership. I was suspicious about rust being under them but there is none from what I can see from behind them and they do look very professionally installed, even upon close inspection. They fit perfectly around the body side moldings.
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #9  
Old 01-26-2008, 05:12 PM
gatorblue92's Avatar
Save the manuals!
 
Join Date: Jan 2006
Location: Delaware
Posts: 3,395
simply beautiful
__________________
1977 MB 240D 4 speed 145K - Nearly Perfect
1995 MB E420 197K - Weekend Toy
2018 Ford F150 5.slow 23K - My DD
2020 Subaru Ascent 10k - Wife's DD

1979 MB 280E 90K - Sold
1983 MB 240D 238K - Scrapped
1984 MB 300D 347K? - Sold
1984 MB 300TD Wagon - 188k - Sold
1987 MB 300E 5 speed 258K - Scrapped
1991 MB 300TE 5 speed 276K - Sold
1993 MB 400E 218K - Sold
1993 MB 400E 130K - Sold
1995 MB E320 Wagon 190k - Sold
Reply With Quote
  #10  
Old 01-26-2008, 05:31 PM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Dang . . .

. . .sweet ride!
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #11  
Old 01-26-2008, 05:56 PM
LUVMBDiesels's Avatar
Dead on balls accurate...
 
Join Date: Aug 2006
Location: Red Lion,Pa
Posts: 2,207
Quote:
Originally Posted by nhdoc View Post
The PO claims the car always had those arch covers...I don't think so unless it was something the dealers installed after the cars left the factory which is certainly possible, just like pinstriping which was routinely done at the dealership. I was suspicious about rust being under them but there is none from what I can see from behind them and they do look very professionally installed, even upon close inspection. They fit perfectly around the body side moldings.

I LOVE that car! It really LOOKS like a Mercedes Benz. Solid, Substantial, and has a real presence. Makes my W126 look like a Taurus
Did you make sure that there is nothing going on behind the covers? I would have to see you get body rot behind those covers.

How is the servo? The main reason I never look at W116 cars is the servo and all the issues it can cause.
__________________
"I have no convictions ... I blow with the wind, and the prevailing wind happens to be from Vichy"

Current
Monika '74 450 SL
BrownHilda '79 280SL
FoxyCleopatra '99 Chevy Suburban
Scarlett 2014 Jeep Cherokee
Krystal 2004 Volvo S60
Gone
'74 Jeep CJ5
'97 Jeep ZJ Laredo
Rudolf ‘86 300SDL
Bruno '81 300SD
Fritzi '84 BMW
'92 Subaru
'96 Impala SS
'71 Buick GS conv
'67 GTO conv
'63 Corvair conv
'57 Nomad
Reply With Quote
  #12  
Old 01-26-2008, 06:02 PM
Jim B.'s Avatar
Who's flying this thing ?
 
Join Date: May 2006
Location: N. California./ N. Nevada
Posts: 3,611
Beautiful car, Marty.

A real classic one, and rare one owner W116 diesels are pretty hard to find, and have been for many years now. You scored a real survivor there.

You have a keen eye - and nose - for finding the very best ones.
__________________
1991 560 SEC AMG, 199k <---- 300 hp 10:1 ECE euro HV ...

1995 E 420, 170k "The Red Plum" (sold)

2015 BMW 535i xdrive awd Stage 1 DINAN, 6k, <----364 hp

1967 Mercury Cougar, 49k

2013 Jaguar XF, 20k <----340 hp Supercharged, All Wheel Drive (sold)
Reply With Quote
  #13  
Old 01-26-2008, 06:02 PM
Dee8go's Avatar
Senor User
 
Join Date: Apr 2006
Location: Arlington, VA
Posts: 7,190
Boy, that car looks clean as a whistle, Marty. Very nice.
__________________
" The market, like the Lord, helps those who help themselves. But, unlike the Lord, the market does not forgive those who know not what they do."- Warren Buffett

OBK #55

1998 Lincoln Continental - Sold
Max 1984 300TD 285,000 miles - Sold
The Dee8gonator 1987 560SEC 196,000 miles - Sold
Orgasmatron - 2006 CLS500 90,000 miles
2002 C320 Wagon 122,000 miles
Reply With Quote
  #14  
Old 01-26-2008, 06:08 PM
83 300SD
 
Join Date: Mar 2007
Location: Shawano, WI
Posts: 691
Beautiful! Congratulations.

John
__________________
Certified Registered Nurse Anesthetist (CRNA)
2002 F250 powerstroke with Plantdrive WVO conversion
1983 300SD 190K miles ,sold
2006 E320 CDI
Reply With Quote
  #15  
Old 01-26-2008, 06:34 PM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by LUVMBDiesels View Post
How is the servo? The main reason I never look at W116 cars is the servo and all the issues it can cause.
The ACC and the heat servo works flawlessly. When I picked it up the blower was DOA and I was pretty peeved that it wasn't disclosed. I could have walked away but the rest of the car was so nice I didn't want to fly back home empty handed. As it turned out the ACC had a broken fuse and as soon as that was replaced (along with all of the others) it came back to life perfectly. Even the A/C (R12) works fine.

The aux fan kept blowing a fuse until I saw that the fuse that was in there was an 8A but the symbol shown on the cover was for 16A so someone put the wrong fuse in there and that's why it was blown. I put the proper one in and the aux fan works fine too.

The biggest problem I had was a tire which shreded before I even made it out of the city limits. It had been repaired and I sensed it would not make it 600 miles home. I put on the spare and went to Sears and had them mount 4 brand new ones - then the rest of the trip was uneventful.

__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page