Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-26-2008, 10:39 PM
Registered User
 
Join Date: Jan 2008
Posts: 13
glow plug relay

hello all i have a 1996 e300d i just replaced all of the glow plugs because one of the old ones were bad figured might as well do it right and change them all since the intake has to come off to get at them.So i changed them now it starts great nice and smooth glow plug light comes on for 7 secs or so then shuts off after its warmed up and i go to start it again after i shut it off light comes on for a few seconds and starts great still.Heres my problem when i start it and drive it for a few minutes the glow plug light comes back on and stays on for a few minutes then shuts off.Nowing how bad it is for glow plugs to stay on for extened periods of time i brought it home to investigate .I checked the impedance of all the glow plugs before i put them in they were matched i checked the impedance between the glow plug connector and the glow plugs the connector that hooks up to the relay that is to the glow plugs turned out to be fine. So hooked up a test light to the output of the relay with the glow plug plug still plugged in and i saw over 12 volts so the plugs are getting power.I also tested the pos 14 volt input connection and saw 14 volts.I took the relay cover off and turned the car on relay engaged then disengaged after 7 seconds or so then when i started the car it re engaged So i shut the car off the next 3 times i started the car the relay engaged and stayed engaged and nver relased until i shut the car off.Oh yeah the battery is new and also before i changed the glow plugs the glow plug light would come on the same way but would have to drive it longer for it to come on.Do i need a new relay if any one could help would be greatly apreciated also if anyone know the wiring for the control wires on the relay would also help so i can test

Reply With Quote
  #2  
Old 01-27-2008, 10:06 AM
Registered User
 
Join Date: May 2007
Posts: 864
Quote:
Originally Posted by scottdarling122 View Post
hello all i have a 1996 e300d i just replaced all of the glow plugs because one of the old ones were bad figured might as well do it right and change them all since the intake has to come off to get at them.So i changed them now it starts great nice and smooth glow plug light comes on for 7 secs or so then shuts off after its warmed up and i go to start it again after i shut it off light comes on for a few seconds and starts great still.Heres my problem when i start it and drive it for a few minutes the glow plug light comes back on and stays on for a few minutes then shuts off.Nowing how bad it is for glow plugs to stay on for extened periods of time i brought it home to investigate .I checked the impedance of all the glow plugs before i put them in they were matched i checked the impedance between the glow plug connector and the glow plugs the connector that hooks up to the relay that is to the glow plugs turned out to be fine. So hooked up a test light to the output of the relay with the glow plug plug still plugged in and i saw over 12 volts so the plugs are getting power.I also tested the pos 14 volt input connection and saw 14 volts.I took the relay cover off and turned the car on relay engaged then disengaged after 7 seconds or so then when i started the car it re engaged So i shut the car off the next 3 times i started the car the relay engaged and stayed engaged and nver relased until i shut the car off.Oh yeah the battery is new and also before i changed the glow plugs the glow plug light would come on the same way but would have to drive it longer for it to come on.Do i need a new relay if any one could help would be greatly apreciated also if anyone know the wiring for the control wires on the relay would also help so i can test
Don't know if you need a new relay or not, but in my car, with the temperature around 25 degrees, when I first start it, the glow plug light will come on for about 15 seconds, and the glow plugs will be activated for about 1 minute to a minute and a half. I have a scanguage attached to the OBD port that gives me a real time readout of the voltage. During that minute or minute and a half, my voltage will usually read 11.8 volts with the lights and defroster on. After that time period, it will bounce up to about 13.2-13.6. My glow plug light does not come on other than the initial startup, or restart. Hope this gives you some useful info.
__________________
96 E300d
Reply With Quote
  #3  
Old 01-27-2008, 08:06 PM
Registered User
 
Join Date: Jan 2008
Posts: 13
glow plug thermo time switch

i have a 1996 e300d mercedes if my glow plug thermo time switch that threads into my motors head went bad would my glow plugs stay on when the key is on whould i see any other sighns if it were bad like the coil light staying on any help would be greatly apreciated thanks

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page