Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-29-2008, 09:59 AM
Registered User
 
Join Date: Jan 2008
Posts: 2
1992 300D Automatic Transmission

My transmission has started slipping between 2nd and 3rd gears. It will engage when I let off on the accelerator. Also, when it is cold (Maine) it will "bang" into gears when it shifts...until it is fully warmed up. Are there any fixes besides a new transmission??

Gary
South Thomaston, ME

Reply With Quote
  #2  
Old 01-29-2008, 10:08 AM
BigBen's Avatar
Registered User
 
Join Date: Oct 2004
Location: Montreal, Canada
Posts: 156
What's your mileage?

Transmission oil changed recently?

Do you have accounts of maintenance history on the vehicle?

Have you checked for proper vacuum from the vacuum pump, do you have a harder break pedal? I had my vacuum pump break a while back and it gave hard transmission shifts, but had no signs of slippage though...

Bye,
__________________
BigBen

'98 E300 Turbodiesel 244 000km
RIP '92 300D 2,5 Turbo 632 859,4km due to engine failure
Reply With Quote
  #3  
Old 01-29-2008, 12:41 PM
pmari's Avatar
OM606.962 177hp 330nm
 
Join Date: Oct 2004
Location: L.I. N.Y.
Posts: 1,033
I also recently had transmission funkyness...Turned out to be dirty fuel filters
__________________
1999 E300DT (131,800) 154,000 Black on Black SOLD

2006 CLK 500 coupe Capri Blue on Grey (zoom,zoom)
47,000mi

04 VW TDI Passat 80,000mi
(Techno)

How to eliminate oil dependency through market-driven approaches.
“We could cut oil use in half by 2025, and by 2040, oil use could be zero,”

The Sound of Diesel Speed
Ode to MB
Reply With Quote
  #4  
Old 01-29-2008, 04:19 PM
Registered User
 
Join Date: Jan 2008
Posts: 2
Quote:
Originally Posted by 92300D View Post
My transmission has started slipping between 2nd and 3rd gears. It will engage when I let off on the accelerator. Also, when it is cold (Maine) it will "bang" into gears when it shifts...until it is fully warmed up. Are there any fixes besides a new transmission??

Gary
South Thomaston, ME
Mileage about 160,000. Transmission oil changed within past year.

Thanks for your response.

Gary
Reply With Quote
  #5  
Old 01-29-2008, 09:29 PM
oldiesel's Avatar
Registered User
 
Join Date: May 2007
Location: florida
Posts: 677
there is a spring kit available thats is supposed to address the 2-3 shift slipping (sometimes called flare here) it requires removing the transmission pan and a few parts of the valve body,not a big job if you have a heated garage and a lift.My nearest MB dealer quoted me $10.00 for the kit. Do a search here for" K 1 kit " you will find more information than you need. I think the harsh shift when cold is normal. My $.02 Don

__________________
Red Green "This is only temporary,Unless it works!"

97 E300D 157000 miles
87 300TD ?141k? miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page