Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 03-04-2008, 12:20 PM
TheDon's Avatar
Open Discussion Moderator
 
Join Date: Oct 2005
Location: Windermere,FL
Posts: 13,205
I always made sure the water in the old battery was topped up, with distilled.

I'll call DAP in a little
__________________

|1983 300D| OM617 239k Miles|Red|"Passion"|
|1982 300D Euro|OM617 NA| Thistle Green|"Granny Smith|
Reply With Quote
  #17  
Old 03-04-2008, 12:57 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 21,322
Quote:
Originally Posted by tangofox007 View Post
My daughter would not look at a voltmeter unless it sent her a text message!!!
You have come up with an excellent idea. Instead of gauges and “idiot lights” the cars computer calls you on your cell phone and tells you something is wrong. I the case of your Daughter the computer would call her and you also to let both of you know something is wrong.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #18  
Old 03-04-2008, 01:30 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Quote:
Originally Posted by TheDon View Post
I always made sure the water in the old battery was topped up, with distilled.

I'll call DAP in a little
If you have to add water, something is wrong.
Reply With Quote
  #19  
Old 03-04-2008, 01:42 PM
I'm thinkin, I'm thinkin.
 
Join Date: Jul 2003
Location: Arlington, Texas
Posts: 440
Quote:
Originally Posted by Jordan G View Post
That reminds me (the equinox part).....the past weekend I tried replacing the battery and cables on my Dad's '96 vette....and I had to remove the freaking fender just to get it out! I suppose performance trumped future maintenance access.

It was such a PITA though.....the positive cable post was completely corroded too and I had to order a new cable from the dealer ($95) and it's impossible to replace, as it's all tucked in behind the rear of the block and it branches off 3 or 4 different ways. Just a nightmare. Finally, I just said screw it.....threaded the old post back into a new battery (got it started) and told him to deal with it (or have a mechanic do it). I'm such a bad son.
Next time try pulling the cruise control unit out of the way and lifting the battery straight up..
__________________
Sharing my partner's 2012 Forte 5dr SX til I find my next 123 or 126..
-
Do I miss being a service advisor ???
Reply With Quote
  #20  
Old 03-04-2008, 01:47 PM
Jordan G's Avatar
Registered User
 
Join Date: Sep 2007
Location: Lancaster, PA
Posts: 389
Quote:
Originally Posted by AdvisorGuy View Post
Next time try pulling the cruise control unit out of the way and lifting the battery straight up..
I contemplated doing that....I really did....but it looked more painful than the fender (only 4 bolts). Thanks for the tip though....I did find similar advice (removing the fender) on a vette forum after I had already attempted it. I think the ASR was in the way too? I have no idea what that is.....some kinda slip regulator?

Strange design....but I suppose you should only have to do it every 5-6 years or so. Hell, I could sit in the engine bay of my 240d......it was quite a different experience.
__________________
1981 240d - 135k - Arlene
Reply With Quote
  #21  
Old 03-04-2008, 04:34 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
My dad's car has a 10 year old Energizer 100A (1000CCA) battery in it. Starts the car easily every time right away, even at 0F. Must be a cold weather thing.
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #22  
Old 03-04-2008, 09:08 PM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
My 300D has a MB battery from 2001 that I pulled out of the trash pile, tested, recharged and put in my car about 3 years ago, still going strong
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #23  
Old 03-04-2008, 09:17 PM
TheDon's Avatar
Open Discussion Moderator
 
Join Date: Oct 2005
Location: Windermere,FL
Posts: 13,205
weird..

Discount auto's battery tester is set for lower compression engines. I had to tell the guy that 300 amps is not nearly enough for my cars starter to even turn. I kept telling him its for a diesel.. a diesel .. high compression.. squish ignite.. etc... and this guy was the "manager"
__________________

|1983 300D| OM617 239k Miles|Red|"Passion"|
|1982 300D Euro|OM617 NA| Thistle Green|"Granny Smith|
Reply With Quote
  #24  
Old 03-04-2008, 09:58 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Quote:
Originally Posted by Johnhef View Post
My 300D has a MB battery from 2001 that I pulled out of the trash pile, tested, recharged and put in my car about 3 years ago, still going strong
I have a MB battery too. They rock. I had to buy mine though.
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #25  
Old 03-04-2008, 09:59 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Down in sunny Florida, 300A should indeed be enough to start your engine. Perhaps your starter is getting old and taking too much current.
Reply With Quote
  #26  
Old 03-04-2008, 10:01 PM
TheDon's Avatar
Open Discussion Moderator
 
Join Date: Oct 2005
Location: Windermere,FL
Posts: 13,205
starter looks to be a bosh reman unit..


It spins nice and fast. After glowing it catches and purs after the first whirr
__________________

|1983 300D| OM617 239k Miles|Red|"Passion"|
|1982 300D Euro|OM617 NA| Thistle Green|"Granny Smith|
Reply With Quote
  #27  
Old 03-04-2008, 10:02 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
Well, 300A at 10V is over 4hp. How much do you suppose it should take?

Most gas cars start with about 100A or less in warm weather.
Reply With Quote
  #28  
Old 03-04-2008, 10:06 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 14,861
Quote:
Originally Posted by Matt L View Post
Well, 300A at 10V is over 4hp. How much do you suppose it should take?

Most gas cars start with about 100A or less in warm weather.
The starters on these cars are 1.2kw power output (for the turbo engines) which is about 1.6 horsepower at 12V, a bit less at 10V. So it has to be lower than 300A, thats for sure.
__________________
-diesel is not just a fuel, its a way of life-
'89 420SEL 168k - mine (OC-170,000)
'93 190D 2.2 - 223k - mine (OC-222,700)
'01 E320 Wagon - 149k - mine (OC-154,000)
'05 C240 4matic Wagon - 153k - wifes (OC-154,500)
'01 E320 - 162k - Dad's (OC-163,500)
'07 E350 Wagon - 116k - dad's (OC-121,500)
'02 E320 - 193k - Brother's (OC - 192,000)
'09 E350 4matic Sedan - 84k - Brothers (OC-85,500)
Reply With Quote
  #29  
Old 03-04-2008, 10:07 PM
TheDon's Avatar
Open Discussion Moderator
 
Join Date: Oct 2005
Location: Windermere,FL
Posts: 13,205
my mechanic friend told me that the test Discount auto did is only sufficient for gas cars reason why it was showing my battery as being good.


I'm not going to question the starter at all since its fairly new( last owner installed it).. it spins fast.. it works
__________________

|1983 300D| OM617 239k Miles|Red|"Passion"|
|1982 300D Euro|OM617 NA| Thistle Green|"Granny Smith|
Reply With Quote
  #30  
Old 03-04-2008, 10:08 PM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,187
IMO, she's jealous of you spending too much time with "the Donna". Ever thought of getting 'Eva Braun' something for V-day? A full body wax, perhaps? A nice undercarriage spray at the spa? Slip a little something new in her tank to give some variety?
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page