Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

LinkBack Thread Tools Display Modes
Old 03-06-2008, 09:41 AM
Registered User
Join Date: Mar 2008
Posts: 11
HVAC - 300TD airflow issues - need help

1983 300TD

AC is working but cannot get cool air to flow from vents. Air is blowing, but it is hot air. Checked freon and it is full. Compressor is working.

Reply With Quote
Old 03-06-2008, 06:14 PM
aaronkobi's Avatar
Registered User
Join Date: Feb 2008
Posts: 140
Sounds like your monovalve is dead... from what I understand, when they die, their "default" setting is full ON (meaning full heat, even if the AC is on). When I bought my 300TD in Florida, the monovalve was dead, but instead of fixing it, someobody had plugged the hose running into it with a wooden dowel. Apparently somebody was too cheap to replace it, and since the car was in florida, that was their... uuuh... slightly backwards way of correcting the problem.
1984 300TD Wagon
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page