Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2008, 02:09 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Unhappy Randon runon with my 1982 240D

Hello All,

I am "just" starting to have some random run on with my 1982 240D. It's happening about 2 times per week. Is there a quick diagnosis and fix?

Thanks,
Allan
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #2  
Old 04-07-2008, 02:13 PM
Stumbler
 
Join Date: Jan 2007
Posts: 38
I have the same problem, my 250d runs on for a good five seconds sometimes, i have heard it might be somthing called the cut-off solenoid, but haven't looked into what they jiggery pokery that is yet?
__________________
1989 250TD the Red Fokker
Reply With Quote
  #3  
Old 04-07-2008, 02:15 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,026
If a 240d runs for a bit before turning off its probably a vacuum leak in the system, or the shutoff valve is going bad. Pretty simple to diagnose. Hook up the shutoff to a mity vac, or to your mouth, and pump/suck on the line. If it shuts off fast, then the issue is elsewhere (vac leak in the system)...start checking rubber connectors and such for cracking or other issues.
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 78k - mine - (OC-80,500)
'17 Metris(VITO!) - 8k - wifes (OC-10k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'89 420SEL 166k - mine (OC-167,000)
'01 E320 - 171k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 49k - dad's (OC-52,000)
'09 E350 4matic Sedan - 129k - Brothers (OC-128,000)
Reply With Quote
  #4  
Old 04-07-2008, 03:29 PM
Narcoleptic's Avatar
diesel huffer
 
Join Date: Sep 2007
Location: Crafton, TX
Posts: 38
I sometimes have this, but its after I start the engine, move the car, and shut it off. It only seems to happen when the engine is warm, and run for 30 seconds to a minute.
__________________
1982 240D
1993 Mazda Miata LE
1991 Mazda MPV
1993 Volvo 940 Turbo Wagon
Reply With Quote
  #5  
Old 04-07-2008, 03:33 PM
winmutt's Avatar
85 300D 4spd+tow+h4
 
Join Date: Apr 2006
Location: Atl Gawga
Posts: 9,329
Narc: your not pulling enough vacuum, more than likely small leak.

More than likely for all it is small vac leaks causing the problem.
__________________
http://superturbodiesel.com/images/sig.04.10.jpg
1987 300D Sturmmachine
1991 300D Nearly Perfect
1994 E320 Cabriolet
1995 E320 Touring
2001 Eurovan FOR SALE
1985 300D car, sold and missed.
OBK #42
Reply With Quote
  #6  
Old 04-08-2008, 01:23 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
does anyone have some pics or pdf's of the vacumme setup you could send me. Also, why is it only happening randomly? 1-2 times per week.
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #7  
Old 04-08-2008, 01:31 PM
Jimmy Joe's Avatar
peace out
 
Join Date: May 2004
Location: California central coast
Posts: 1,004
Check that engine shut-off solenoid asap; when mine went, a diaphram ruptured in it that allowed oil to be drawn up into the vacuum lines, quite a mess to clean up and can damage other components wherever it travels.

If your shutoff is bad, make sure you read the warnings about improper installation, as a run-away engine could result!!!

That said, it is an easy job (if not a tad intimidating) and the shutoff can be had for cheap if you shop around.
__________________
Think Alternative Energy!
300CD '80 (now gone but not forgotten...)
Reply With Quote
  #8  
Old 04-09-2008, 04:29 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
where is it located?
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page