Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-08-2008, 10:11 PM
Rebe
Guest
 
Posts: n/a
rough idle

I have a question on a 240D. It starts great & idles good. If you take off and drive on the road like 15 miles or so then come to a stop sign. It wants to run a bit rough and shakey & not the nice smooth idles when it was colder. I have ran a lot of cleaner thru it, but I thought if it was a clog it would do it when it was cold, as well. The filters are clean and new. I haven't cleaned the tank screen.
Reply With Quote
  #2  
Old 04-08-2008, 11:19 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 27,353
When was the last time the valves were adjusted?
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #3  
Old 04-09-2008, 06:26 AM
Rebe
Guest
 
Posts: n/a
It's been like a year ago now.
Reply With Quote
  #4  
Old 04-09-2008, 08:06 AM
LUVMBDiesels's Avatar
Dead on balls accurate...
 
Join Date: Aug 2006
Location: Red Lion,Pa
Posts: 2,207
Rack damper bolt?

Check to see if it is the gold colored one. If not you should replace it.

Do a search on Rack Damper Bolt for lots of posts onthe subject.
__________________
"I have no convictions ... I blow with the wind, and the prevailing wind happens to be from Vichy"

Current
Monika '74 450 SL
BrownHilda '79 280SL
FoxyCleopatra '99 Chevy Suburban
Scarlett 2014 Jeep Cherokee
Krystal 2004 Volvo S60
Gone
'74 Jeep CJ5
'97 Jeep ZJ Laredo
Rudolf 86 300SDL
Bruno '81 300SD
Fritzi '84 BMW
'92 Subaru
'96 Impala SS
'71 Buick GS conv
'67 GTO conv
'63 Corvair conv
'57 Nomad
Reply With Quote
  #5  
Old 04-09-2008, 10:21 AM
Bajaman's Avatar
Registered User
 
Join Date: Mar 2005
Location: Bern, Switzerland
Posts: 713
616 does not have the rack dampener
__________________
For Sale: 1982 MB 300TD
1995 Chevrolet Suburban 6.5TD

Sold: 1980 IH Scout Traveler- Nissan SD33T Diesel
Reply With Quote
  #6  
Old 04-09-2008, 11:13 AM
LUVMBDiesels's Avatar
Dead on balls accurate...
 
Join Date: Aug 2006
Location: Red Lion,Pa
Posts: 2,207
Quote:
Originally Posted by Bajaman View Post
616 does not have the rack dampener
My bad
__________________
"I have no convictions ... I blow with the wind, and the prevailing wind happens to be from Vichy"

Current
Monika '74 450 SL
BrownHilda '79 280SL
FoxyCleopatra '99 Chevy Suburban
Scarlett 2014 Jeep Cherokee
Krystal 2004 Volvo S60
Gone
'74 Jeep CJ5
'97 Jeep ZJ Laredo
Rudolf 86 300SDL
Bruno '81 300SD
Fritzi '84 BMW
'92 Subaru
'96 Impala SS
'71 Buick GS conv
'67 GTO conv
'63 Corvair conv
'57 Nomad
Reply With Quote
  #7  
Old 04-09-2008, 11:30 AM
Registered User
 
Join Date: Nov 2006
Location: FL
Posts: 507
what type of cleaner

what type and method of cleaner did you use?

Have you changed your fuel filters lately, or had any issue with your fuel tank screen?
__________________
85 300CD Turbo "Das Polluter" 230K sold for $3,000

98 BMW 323is
Reply With Quote
  #8  
Old 04-09-2008, 05:37 PM
Rebe
Guest
 
Posts: n/a
I change my fuel filters methodically. I do it at every oil change. I wondered about an injector, but I thought it would happen cold or hot. Also, if the tank screen is clogged would it not be rough running, as well, cold or hot. To test the tank screen I wondered if you fill the tank pretty well full & pull the hose off of the metal fuel line it should be a good full stream come out? It has been doing this same senario ever since I acquired the car. It's not a unliveable deal, but would be nice if it were smooth running when ldling hot. It does not seem to do it though hot if you shift into park. It's only like that when in drive and sitting at a stop.
Reply With Quote
  #9  
Old 04-10-2008, 02:00 AM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 27,353
Quote:
Originally Posted by Rebe View Post
It's been like a year ago now.
It has been a year since I adjusted my valves also and I think it is due to be done again sometime befoe the end of this month.
Injectors:I changed the injectors on my car and the idle improved. I only found out later that the pintles in the nozzles are drilled with a tiny hole down the center and cross drilled up further on the pintal (see the pic). When I looked at the old nozzles I found that the tiny holes were plugged with carbon.
Recently at the junk yard I pulled a set of injectors off of an 82 300SD. All but one of the injecors appeared to pop test OK but when I looked all of the drilled holes were plugged with carbon. The injectors could not have been working correctly.
I believe that the plugged holes would effect the idle.
This is a line drawing of the spray nozzle by itself.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #10  
Old 04-10-2008, 10:32 AM
Gene
 
Join Date: Mar 2007
Location: Buffalo NY
Posts: 1,082
Are you sure thats not the female reproductive system?

Nice diagram 911.

Also, the pop pressures might be off, springs do lose tension, and they tend to show it when warm.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page