Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-13-2008, 10:00 PM
turbobenz's Avatar
Registered User
 
Join Date: Nov 2007
Location: Cameron Park CA
Posts: 1,863
help me help my sunroof

im getting the sunroof working on my 300sd w126. Before I started, it was closed fully and the only thing it did was make sound from the motor turning in the trunk. I figured it was a broken cable so i decided to tackle it today. I was able to manually push the sunroof open, and could close it but not get it to tilt back up. So i took apart the track and pulled the entire thing out. Apparently the owner before me (ernie of ernies ind. mercedes service) had it for 8 years and decided at one point to remove the cable entirely so he could close it, i guess. So i took the cable from my w123 parts car and fed it down into the track and then pressed the button to feed it. It will not feed in unless you help it, but it pushes fine. When its retracting, it grinds unless you help it, again, pushing out (as if the sunroof were closing) it works fine. Any ideas? Im thinking its down in the motor (the gear may be stripped, this car has 354k on it). Has anyone had this problem before? Is a w123 sunroof cable the same as a w126?
__________________
1981 300SD 512k OM603


Reply With Quote
  #2  
Old 04-13-2008, 10:04 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
I would think it's the same system, yet the cable may be longer in a 126.
Did you clean out the tube? Grease the cable when you put it in?
__________________
83 SD

84 CD
Reply With Quote
  #3  
Old 04-13-2008, 10:05 PM
Registered Hack
 
Join Date: Mar 2008
Posts: 4,612
No experience.. but I agree with your motor theory. The pinion is either slipping ,or the mating gears are stripped.. guess Ernie couldn't find those parts.

Good luck
Reply With Quote
  #4  
Old 04-13-2008, 10:08 PM
92 300D 2.5L OBK #59
 
Join Date: Feb 2007
Location: Central FL
Posts: 1,108
http://mb.auto.pl/wis/w124/CD02/Chassis/77-195.pdf

http://mb.auto.pl/wis/w124/CD02/Chassis/77-140.pdf

I think there is a clutch adjustment you can make.
__________________
92 300D 2.5L OM602 OBK #59

Last edited by bobodaclown; 04-13-2008 at 10:15 PM.
Reply With Quote
  #5  
Old 04-13-2008, 10:09 PM
turbobenz's Avatar
Registered User
 
Join Date: Nov 2007
Location: Cameron Park CA
Posts: 1,863
a sort of adjustment on the motor is what I was thinking also, i have the trunk apart i will go look
__________________
1981 300SD 512k OM603


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page