Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2008, 07:09 PM
Registered User
 
Join Date: Jun 2008
Posts: 32
$%#$!!! Battery!!

Battery keeps going dead. when fully charged starter still turns slow...real slow. and the battery light on my instument cluster lights brightly when reved high, but not noticable when at idle.. These bats are expensive. Please help.
Reply With Quote
  #2  
Old 06-30-2008, 07:10 PM
ForcedInduction
Guest
 
Posts: n/a
Get your battery and charging system tested.
Reply With Quote
  #3  
Old 06-30-2008, 07:23 PM
Jimmy Joe's Avatar
peace out
 
Join Date: May 2004
Location: California central coast
Posts: 1,004
How do you know the battery is fully charged?
__________________
Think Alternative Energy!
300CD '80 (now gone but not forgotten...)
Reply With Quote
  #4  
Old 06-30-2008, 08:14 PM
patbob's Avatar
Its a Whatsit
 
Join Date: Oct 2006
Location: Portland, OR
Posts: 837
Also, have you checked the acid levels in the battery's cells? Should cover the plates and a bit more. Top off with distilled water.

Clean the mating surfaces of the battery terminals and inside of the battery cable clamps, reassemble.

If the battery won't hold a charge, have you checked for a current drain on it when the engine is off? Some things, like the power antenna, are prone to failure and can draw amps out of the battery constantly. Sometimes the alternator diodes go and leak, reducing the alt's effecitveness and becoming a current draw on the battery when then engine isn't running.

With the alt light behavior, I'd suspect the alt ground or engine ground.

Check the alternator belt tension. Also check all the connections to it -- look for loosness or corrosion, or just skip that and remove them all, clean the mating electrical surfaces until bright and shiney, and reassemble using dielectric grease.

Also, sometimes the voltage regulators brushes wear out and fail to make contact, but then the alt light usually behaves differently.
__________________
'83 300DTurbo http://badges.fuelly.com/images/smallsig-us/318559.png

Broadband: more lies faster.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page