PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   83 300sd trans quit (http://www.peachparts.com/shopforum/diesel-discussion/227724-83-300sd-trans-quit.html)

blackestate 07-15-2008 05:35 PM

83 300sd trans quit
 
The trans was slow at engaging, but ran great. Parked the car, now it does not engage at all.
Bad trans or something else?
Bought a replacement but how do I make sure that it is the trans before I change it out?

thanks

Oracle12345 07-15-2008 07:03 PM

Can you go into any gears?

Does up or down shift?

blackestate 07-16-2008 01:27 PM

It does not go into any gears, except right when first put into gear, feels like it engages for a sec, then drops out.

checked fluid, ok, linkage seems to be working fine.

H-townbenzoboy 07-16-2008 02:08 PM

You need to drop the pan and see if there are any metal shavings in there.

blackestate 08-05-2008 04:36 PM

2 Attachment(s)
Here are a couple of photos,
The fluid looks pink, Real pink, not just some water?
The other is of the pan. Nothing, but the normal fine grime at the bottom of the pan.
I think I will put it together, drain the TC, and see what happens. But why the pink fluid?
any ideas, or anything I am missing?

thanks



Attachment 57797 Attachment 57798

bgkast 08-05-2008 05:17 PM

Maybe you have a leak in the trans cooler that is inside the radiator


All times are GMT -4. The time now is 06:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website