Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-15-2008, 05:35 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
83 300sd trans quit

The trans was slow at engaging, but ran great. Parked the car, now it does not engage at all.
Bad trans or something else?
Bought a replacement but how do I make sure that it is the trans before I change it out?

thanks
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #2  
Old 07-15-2008, 07:03 PM
Registered User
 
Join Date: Jul 2007
Location: USA
Posts: 2,156
Can you go into any gears?

Does up or down shift?
__________________
1986 300SDL, 211K,Dealership serviced its whole life
1991 190E 2.6(120k)
1983 300D(300k)
1977 300D(211k)
Reply With Quote
  #3  
Old 07-16-2008, 01:27 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
It does not go into any gears, except right when first put into gear, feels like it engages for a sec, then drops out.

checked fluid, ok, linkage seems to be working fine.
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #4  
Old 07-16-2008, 02:08 PM
H-townbenzoboy's Avatar
Now Y2K Compliant
 
Join Date: Jul 2003
Location: Houston, TX
Posts: 4,200
You need to drop the pan and see if there are any metal shavings in there.
__________________
Current Vice-President of MBCA|Houston

81 MB 300SD, 82 MB 300D Turbo (sold), 04 Lincoln Town Car Ultimate

Sooner or later every car falls apart, ours does it later!
-German Narrator in a MB Promotion Film about the then brand new W123.
Reply With Quote
  #5  
Old 08-05-2008, 04:36 PM
blackestate's Avatar
Registered User
 
Join Date: Aug 2005
Location: Washington State
Posts: 948
Here are a couple of photos,
The fluid looks pink, Real pink, not just some water?
The other is of the pan. Nothing, but the normal fine grime at the bottom of the pan.
I think I will put it together, drain the TC, and see what happens. But why the pink fluid?
any ideas, or anything I am missing?

thanks



83 300sd trans quit-100_5236.jpg 83 300sd trans quit-100_5235.jpg
__________________
83 300SD Dark Silver Dark brown inside
Reply With Quote
  #6  
Old 08-05-2008, 05:17 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Maybe you have a leak in the trans cooler that is inside the radiator
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page