Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-05-2008, 04:07 PM
Registered User
 
Join Date: Aug 2008
Posts: 1
firecraker popping engine noise 1986 190d

i am new to this so thank for any replies. i have a 1985 190d 2.2
when i start the car there is a loud popping firecracker noise and spark that happens on the top of the engine. it is where a wire is attached to a nut on the top of the engine. it pops and sparks, pops and sparks, very loud and smokes alot. what is happening, is there afix?
thanks for any replies.
Reply With Quote
  #2  
Old 08-05-2008, 04:29 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
I think we'll need a picture for this one...
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #3  
Old 08-05-2008, 04:41 PM
Registered User
 
Join Date: Apr 2005
Location: Northern NY
Posts: 362
There is always a fix! Sounds as though you have a dead short, probably in that part of the harness that contains the glow plug wiring. My guess is that it has melted insulation off several of the wires in the cluster. Pick that section up and get a look at it all around. Cut the burned/melted section of the loom apart to determine the extent of the problem and then repair the wires as necessary. Be certain to use like sized wire for any replacement and insulated connectors for your splices. I usually use heat shrink tube over splices to keep any water out.

Good luck,
Jim
__________________
2005 C240 4matic wagon (daily driver)
87 190D - 225K (on loan)
85 190D - 312K (on loan)
2011 Subaru Legacy AWD (Wife's)
Reply With Quote
  #4  
Old 08-05-2008, 04:49 PM
Registered User
 
Join Date: Apr 2005
Location: Northern NY
Posts: 362
Should have read the original post more closely. I could be wrong (certainly wouldn't be the first time) but I believe that the only wire terminated at the top of the engine is a ground connected to the intake manifold just behind the fuel filter. It comes out of the wire cluster that I referenced in my previous post. Check over carefully as I mentioned before.

Jim
__________________
2005 C240 4matic wagon (daily driver)
87 190D - 225K (on loan)
85 190D - 312K (on loan)
2011 Subaru Legacy AWD (Wife's)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page