Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-22-2008, 10:03 PM
Registered User
 
Join Date: Jul 2008
Location: Vancouver, WA
Posts: 38
IP noise!!!

I have an issue. My injection pump makes a squeeling noise when the engine rpm's go above 2000. Has anyone had this problem? anything that I should check before taking it to the shop? All advice is appreciated
Reply With Quote
  #2  
Old 08-22-2008, 10:22 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
That's a new one. You positive it's the IP?
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #3  
Old 08-22-2008, 10:28 PM
Registered User
 
Join Date: Jul 2008
Location: Vancouver, WA
Posts: 38
I'm 99% sure. I can't even find a place online that sells an IP! The car runs fine other than the noise from the IP.
Reply With Quote
  #4  
Old 08-22-2008, 11:38 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 26,950
IP Camshaft Bearings go bad ounce in a while as well as the Rollers and the parts of the Fuel Supply.
Try a Mechanics Steoscope or a substitute (I use a cut to size wooden broom handle) and see if you can pin point where the sound is comming from.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #5  
Old 08-22-2008, 11:52 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Quote:
Originally Posted by Zackm View Post
I'm 99% sure. I can't even find a place online that sells an IP! The car runs fine other than the noise from the IP.
Junk yard is your best bet, they rarely go bad. There is an '85 300D in the Vancouver LKQ yard, and several in the Damascus Pull-a-part

Where in Vancouver are you?
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #6  
Old 08-23-2008, 05:34 AM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
It helps to know what year and model it is. The early ones have an oil sump and if yours is one of them it might just need oil.
__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
  #7  
Old 08-23-2008, 12:47 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 26,950
His/Her profile has 85 300D.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #8  
Old 08-23-2008, 05:53 PM
gsxr's Avatar
Unbanned...?
 
Join Date: Aug 2001
Location: USA
Posts: 8,002
I'd pull all the V-belts off the engine first, before condemning the IP. But anyway, used OM617 IP's are plentiful and cheap.

It would help if you post the year & model in the first post of your threads, or just create a signature file that shows this information. Troubleshooting information can be vastly different between years & models.

__________________
Dave M.
Boise, ID

1997 E420 - 155kmi (Bugeyes)
1994 E420 - 145kmi (Blondie)
1993 500E - 193kmi (Lollipop)
1992 400E - 189kmi (Stinky Dirty)
Check out my website photos, documents, and movies!
Reply With Quote
  #9  
Old 08-23-2008, 10:31 PM
Registered User
 
Join Date: Jul 2008
Location: Vancouver, WA
Posts: 38
Sorry for not posting my year and model. It's an 85 300D. I used a long screwdriver and put it on the IP the noise is definately coming from it. Now I just need to replace it
Reply With Quote
  #10  
Old 08-23-2008, 10:34 PM
DieselClack's Avatar
Registered User
 
Join Date: May 2008
Location: Arizona
Posts: 189
Quote:
Originally Posted by Zackm View Post
Sorry for not posting my year and model. It's an 85 300D. I used a long screwdriver and put it on the IP the noise is definately coming from it. Now I just need to replace it
Remove the oil return tube and start the motor for a few seconds and confirm that your IP is getting oile from the engine oil pump.
__________________
Save and enlarge for explanation of financial crisis!

http://www.mobile-phone-solutions.com Advice on cell phone signal antennas and amplifiers.
Reply With Quote
  #11  
Old 08-23-2008, 11:17 PM
Registered User
 
Join Date: Jul 2008
Location: Vancouver, WA
Posts: 38
Will do dieselclack. I didn't even think of that!
Reply With Quote
  #12  
Old 08-24-2008, 01:56 AM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Quote:
Originally Posted by Zackm View Post
Sorry for not posting my year and model. It's an 85 300D. I used a long screwdriver and put it on the IP the noise is definately coming from it. Now I just need to replace it
The '85 IP has an electronic rack sensor on it, so you will need another '85 IP. Like I said above there is a '85 in the Vancouver junk yard.
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #13  
Old 08-24-2008, 01:57 AM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Quote:
Originally Posted by DieselClack View Post
Remove the oil return tube and start the motor for a few seconds and confirm that your IP is getting oile from the engine oil pump.

Oil return tube?
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #14  
Old 08-24-2008, 02:06 AM
Registered User
 
Join Date: Jul 2008
Location: Vancouver, WA
Posts: 38
Thanks bg I'm going to call them tomorrow or if they're closed on Monday. Thanks!!!
__________________
85 300D Turbo!
Reply With Quote
  #15  
Old 08-24-2008, 02:08 AM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
They are open tomorrow. You will have to pull it your self. The car will be the first thing you see when you enter the yard, it's right by the doors.
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page