Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-15-2008, 03:28 PM
Registered User
 
Join Date: Sep 2002
Location: Utah
Posts: 414
No heat 85 300dt.. I searched...where to start

I searched a bit and found some related info.
Posting for a friend with heater woes....

85 300d turbo and I get no heat ... motor is up to temp and the AC works fine.
I am still a little puzzled by the icons on controls on the console but they work.... I am used to the 240 on -off knob.
Thermostat seems to be good and it does not over heat.
Is the heater electrical contrlled or vacuum or both

opinions and links appreciated..

bennett

__________________
81' 240d 4 spd 140k on the clock
Reply With Quote
  #2  
Old 09-15-2008, 03:34 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
1. Check the monovalve. It could be stuck closed, or some one wired it to recieve a constant 12 volts. The monovalve is supposed to open, allowing hot water to flow, at 0 volts.

2. Also check to make sure the heater core was not bypassed.
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
  #3  
Old 09-15-2008, 03:46 PM
Registered User
 
Join Date: Sep 2002
Location: Utah
Posts: 414
Core was not Bypassed... he had heat up until a few weeks ago.
The fan blower works and blows good air.. just no heat
fuses are good... did burn one a few weeks ago when the hood pad fell off under the hood and laid on the motor and she got warm but not overheated.

Where is the monovalve?
__________________
81' 240d 4 spd 140k on the clock
Reply With Quote
  #4  
Old 09-15-2008, 03:48 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
Check to see if the monovalve is getting juice or not. In the heat setting it gets 0 volts, and it's supposed to open. It is mounted on the firewall, passenger side near the valve cover.

__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page