Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 10-06-2008, 11:15 AM
DeliveryValve's Avatar
Chairman of my Benz
 
Join Date: Jun 2006
Location: Central California
Posts: 4,002
Quote:
Originally Posted by 79Mercy View Post
i'll take a look. Also, I can feel the pop in the floor when it happens.
Even with faulty motor mount setup, you'll feel it pop on the floor.
__________________
1983 123.133 California
- GreaseCar Veg System


Reply With Quote
  #17  
Old 10-06-2008, 11:24 AM
Phil's Avatar
Registered User
 
Join Date: Dec 2004
Location: Sonoma County, California
Posts: 1,062
I agree with others here that it is probably a guide rod mount. Look at the rubber boot on the joint and if it is torn you should replace very soon. While you are checking this look at the ball joint boots and if they are torn replace them also. There are many right ups about this so search around. When I replaced the guide rod mounts on my car I had a friend use a long wrecking bar to pull the lower arm foward when I was starting to put it back together and it was no problem.
__________________
1983 300SD
200000miles
Reply With Quote
  #18  
Old 12-06-2008, 11:32 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
I just replaced guide rod mounts, LCA bushings and ball joints and it still pops.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #19  
Old 12-08-2008, 11:50 AM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
its my left motor mount. I stood by the passenger fender and pulled the motor to me and if i pulled it hard enough I would hear a loud pop. Now I need to replace motor mounts. Thanks everyone
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #20  
Old 12-08-2008, 02:53 PM
mobetta's Avatar
(Oo{-I-}oO)
 
Join Date: Mar 2006
Location: minnesota,hey.
Posts: 1,840
at least you have a new tight front end now, good for a few hundred thousand more miles.
__________________
1984 123.193 372,xxx miles, room for Seven.

1999 Dodge Durango Cummins 4BTAA 47RE 5k lb 4x4 getting 25+mpgs, room for Seven.
Reply With Quote
  #21  
Old 12-08-2008, 02:55 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
yeah, I have been needing a new front end for a few years.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page