Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-2008, 11:47 AM
Registered User
 
Join Date: Apr 2008
Location: Stonington, PA
Posts: 4
1983 SD Starting Problems....

About a week ago, I let my SVO converted MB SD sit for three days in a garage due to weather.....slick roads in Pennsylvania. It would not start. My mechanic who installed the greasecar.com kit came over and got it started after letting the battery charge from the jump for a few minutes.

I ran the car for about a half hour including idling and driving.

Sunday, I went to start the car and it wouldn't start again. When I turn the glow plugs on, I let them warm up, the electrical comes on, the locks open (vacuum) but nothing turns over at all. Like the battery is totally dead?

What could be wrong????

Reply With Quote
  #2  
Old 12-22-2008, 12:01 PM
ashedd's Avatar
Registered User
 
Join Date: Aug 2008
Location: Seattle
Posts: 1,790
buy a new batt
Reply With Quote
  #3  
Old 12-22-2008, 12:02 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,354
Battery totally dead? Check the connections on the battery and do a load test on it. If you can't do the load test yourself, take it to an auto parts store. They will do it.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #4  
Old 12-22-2008, 12:07 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,095
Also, check your ground connections batt.-chassis and especially chassis-engine. Once you get it started, check your charging voltage across the battery terminals. It should be nearly 13VDC.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
  #5  
Old 12-22-2008, 03:59 PM
Registered User
 
Join Date: Apr 2008
Location: Stonington, PA
Posts: 4
Dead Battery

Could it be the voltage regulator?????
Reply With Quote
  #6  
Old 12-22-2008, 04:12 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,354
Could be. You need to check voltage at the battery with the engine running to confirm a problem.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #7  
Old 12-22-2008, 04:17 PM
oldsinner111's Avatar
love all animals
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,121
Could be veggie in your secondary fuel filter. Drain filter and fill with kerosene to get started.If you are running one tank setup,blend in 70% diesel.
__________________
veteran,mother german,born in stuttgart,ashamed of what america has turned into,religous,and the right are fecal matter
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page