PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   No A/C, Kickdown, tach (http://www.peachparts.com/shopforum/diesel-discussion/251475-no-c-kickdown-tach.html)

Bio Diesel fool 04-29-2009 02:00 PM

No A/C, Kickdown, tach
 
Traced to combo control unit, replaced but still not working:confused:
Any ideas?
Thanks for reminding me that no one can help without the necessary Info.
Here is where we are at. 1992 300D 2.5 turbo Diesel 602.962
Vin WDBEB28DINB644488
Back ground just rebuilt and reinstalled engine runs great but no A/C limited kickdown no Tach.
Fuses all ck OK
Wiggled A/C Compressor Control Unit A/C compressor kicked on but lost all Trans Kick down.
Current conditions A/C, tach, trans kickdown all Inopperable
Checked; power supply to terminal 1,ground terminal 1, continuity to A/C cllutch from terminal 7 all OK. A/C clutch operates if #7 is powered.
Checked ground signal to terminal 10 through high pressure switch OK.
Terminals 9 & 11 show open untill Relay is installed & than a varring ground signal
Terminal #2 shows ground
Terminal #6 shows open
Terminal #4 shows weak ground that gets better @ WOT.
Don't know where to check from here.
Replaced A/C compressor control no change

DeliveryValve 04-29-2009 02:14 PM

What model of vehicle are you referring to?

Let me guess... 1985 300D or 300SD...

sd300td 04-29-2009 03:44 PM

Quote:

Originally Posted by Bio Diesel fool (Post 2187760)
Traced to combo control unit, replaced but still not working:confused:
Any ideas?

fuse?

Graplr 04-29-2009 04:56 PM

On my SD the blower and kickdown are on the same circuit so when the fuse blows it takes both out along with some other stuff.

Oracle12345 04-30-2009 12:12 AM

knowing the chassis and year would help

babymog 05-01-2009 12:28 AM

Have you checked the fuse on the OVP relay and the relay itself? Sounds like classic symptoms, ... it's the relay with the fuse in the top behind the battery splash-shield.

Bio Diesel fool 05-01-2009 08:46 AM

We replaced the A/C combo control behind the battery splash shield did not see a fuse there. Is there another relay that also operates these systems. The one we replaced is a box with about seven prongs

dieseldan44 05-01-2009 09:02 AM

the Over Voltage Protection Relay, or OVP, is likely the issue.

I dont know where it is on your car, but my 85 has one and will disable those systems if it is broken.

dd

Oldwolf 05-01-2009 10:29 AM

I have the same car (300D 2.5L) but it is a 1993. My Tach does not work either but my A/C operated correctly. Also my Cruise Control does not work right.

I did check the OVP and the fuse is good. How do you check the OVP for proper operation?

I'm hoping this tread will help me too.

Oracle12345 05-01-2009 12:29 PM

i looked at some wiring diagrams it could be that your issue is all interelated. all the inoperable items are control by the ac compressor control unit. The one you got is it from a junkyard or a new one?

Did it do this before rebuilding the motor? Did you check your work to make sure everything is hooked up right?

Other things to consider are the OVP, connector x26, kickdown switch. a/c compressor, wiring, boost cut microswitch. I would also check the EDS system to make sure that is 100% working. Make sure your grounds are not loose or corroded. take a look at the wiring diagrams for things not working and you will see im croming from.

Bio Diesel fool 05-01-2009 03:12 PM

Thank you for responding
It is a new control purchased from Phil @ Peachparts.
Everything but the Tach worked before the rebuild. After the reinstall the kickdown worked partialy ( it would kickdown one notch not 2 when it should have) A/C did not work after rebuild compressor clutch would not engage. While running a test and wiggling the control unit the A/C clutch engaged but than we lost all kickdown. Replaced control unit with new unit still no tach, kickdown,or A/C

JimmyL 05-01-2009 03:41 PM

By "control unit" are you referencing the ovp relay as mentioned above?

sd300td 05-01-2009 03:42 PM

Does the horn work? I ask cause whenever I "kick-down", it blows the fuse that controls the horn, back-up lights, and an AC accessory (not sure which AC part...) Fuse #8 or #14 (?), IIRC?

Oracle12345 05-01-2009 04:51 PM

Download tach.jpg from FileFactory.com

Download ac compressor.jpg from FileFactory.com

ovp and control unit 2 different things.

Bio Diesel fool 05-01-2009 10:06 PM

Thank you all
went back and rechecked OV relay, fuse good so we jumped from battery to out pin and viola the compressor kicked on tach works and she's got more power than ever. Called Phil at Peach parts and ordered the OV relay.
If anyone needs a good used A/C control unit I have one for sale.
Again thanks for all the help could not have done it without all the suggestions :D:):):)


All times are GMT -4. The time now is 02:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website