Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-02-2009, 05:58 PM
Registered User
 
Join Date: May 2007
Location: Greensboro, NC
Posts: 117
Kaehler wiper relay

Since last November, the wipers will only work on the fastest speed. I replaced the wiper relay, which looked like the one highlighted in the second picture: wide, flat metallic case; seven pins. I replaced it because I heard a clicking coming from it each time I turned on the intermittent wipers. I got it from the dealer because I could not find it online. This did not fix the problem, nor did replacing the fuse for the wipers.

When I looked for a wiper relay online, every parts store suggests the one in the first picture: a tall, skinny plastic relay manufactured by KAE. I cannot find where such a relay would go on my car (1978 240D). Does the KAE relay fit the 1978 240D? Where does it install? Thanks in advance for any help.
Attached Thumbnails
Kaehler wiper relay-wiper-relay.jpg   Kaehler wiper relay-wiper-relay2.jpg  
__________________
'Betsy the Getaway Car' : 1978 MB 240D, 582k
'The Mistress of the Sea' : 2001 Giant Boulder, 10.30k
Reply With Quote
  #2  
Old 05-02-2009, 07:12 PM
Registered User
 
Join Date: Apr 2005
Location: Austin, TX
Posts: 631
Quote:
Originally Posted by apsaulters View Post
I replaced the wiper relay, which looked like the one highlighted in the second picture: wide, flat metallic case; seven pins.
There were two styles of pulse wiper relay, I call them the "old" and the "new". The old was larger, aluminum case relay, and the new is the smaller, plastic case relay currently sold by all the parts places. They function identically, but mount into different sockets. If your car is a '78, you will undoubtedly use the "old" style.


Quote:
Originally Posted by apsaulters View Post
I replaced it because I heard a clicking coming from it each time I turned on the intermittent wipers.
This is normal. The clicking is the electronic relay engaging and disengaging.


Quote:
Originally Posted by apsaulters View Post
Since last November, the wipers will only work on the fastest speed.
Your problem is most likely in the wiper switch, motor or wiring, as the pulse wiper relay is only involved in the intermittent function and the "wipe after wash" function.
__________________
Bob
'82 300D Petrol B-G Metallic
Reply With Quote
  #3  
Old 05-17-2009, 09:09 AM
Diz Diz is offline
Registered User
 
Join Date: Dec 2006
Posts: 6
I have a 95 S320 that is doing the same thing...wiper works on high and not intermittent or low. Question is does the W140 series wipers work the same, ie don't bother with the relay- replace the motor or the switch? thanks John
Reply With Quote
  #4  
Old 05-17-2009, 11:49 AM
Registered User
 
Join Date: May 2007
Location: Greensboro, NC
Posts: 117
I'm not sure about the w140, but replacing the combination switch solved my problem.
__________________
'Betsy the Getaway Car' : 1978 MB 240D, 582k
'The Mistress of the Sea' : 2001 Giant Boulder, 10.30k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page