Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-06-2009, 08:58 PM
Registered User
 
Join Date: Apr 2009
Location: Syracuse, NY
Posts: 67
240D Instrument Cluster/Switch lights issue

I swapped dashes today in a 83 240D and for some reason now my instrument cluster and all switch lights wont light up when the lights are turned on. Everything functions fine (all switches work, blower turns on) but they just wont light up. All fuses looked intact. Any ideas?
__________________
1982 240D - 251,000 miles (all parts pulled and for sale, body crushed )
1983 240D 4 speed manual - 233,000 miles
2001 Ford Ranger XLT 4WD
Reply With Quote
  #2  
Old 05-06-2009, 09:13 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 27,913
Ground wires somewhere near the gauges?
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #3  
Old 05-07-2009, 07:44 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Your new cluster may have a failed rheostat.
__________________
83 SD

84 CD
Reply With Quote
  #4  
Old 05-07-2009, 08:47 AM
ForcedInduction
Guest
 
Posts: n/a
Yep. Either the rheostat or the wire trace in the cluster itself is fried.
Attached Thumbnails
240D Instrument Cluster/Switch lights issue-fried.jpg  
Reply With Quote
  #5  
Old 05-07-2009, 08:34 PM
Registered User
 
Join Date: Apr 2009
Location: Syracuse, NY
Posts: 67
Thanks for the replies. Turns out it was a bad rheostat in the new cluster. Put a jumper across and now they are lit up.

Only problem I'm having now is getting the dash switches (dome, antenna, sunroof, defroster) to light when the lights are on. But they were like that when I bought the car. Not after I put a new cluster in.
__________________
1982 240D - 251,000 miles (all parts pulled and for sale, body crushed )
1983 240D 4 speed manual - 233,000 miles
2001 Ford Ranger XLT 4WD
Reply With Quote
  #6  
Old 05-07-2009, 09:10 PM
ForcedInduction
Guest
 
Posts: n/a
The light bulb in the fiber optic spider is probably burnt out. Remove the climate control button unit and you'll see it.
Reply With Quote
  #7  
Old 05-07-2009, 10:12 PM
Registered User
 
Join Date: Apr 2009
Location: Syracuse, NY
Posts: 67
Quote:
Originally Posted by ForcedInduction View Post
The light bulb in the fiber optic spider is probably burnt out. Remove the climate control button unit and you'll see it.
I saw that and wondered if that might be it. Thats the thing that has a bulb sticking inside a small unit with the 3 wires coming out of it and has a couple of bulbs wired to them? Couple bulbs did look foggy and possibly blown. Those bulbs attached should insert into the climate panel correct? They were just tucked back into console and I didn't see the purpose of just having bulbs that light up for no reason?
__________________
1982 240D - 251,000 miles (all parts pulled and for sale, body crushed )
1983 240D 4 speed manual - 233,000 miles
2001 Ford Ranger XLT 4WD

Last edited by Sam82MB240D; 05-07-2009 at 10:33 PM.
Reply With Quote
  #8  
Old 05-07-2009, 10:54 PM
Registered User
 
Join Date: Apr 2009
Location: Syracuse, NY
Posts: 67
Quote:
Originally Posted by Sam82MB240D View Post
I saw that and wondered if that might be it. Thats the thing that has a bulb sticking inside a small unit with the 3 wires coming out of it and has a couple of bulbs wired to them? Couple bulbs did look foggy and possibly blown. Those bulbs attached should insert into the climate panel correct? They were just tucked back into console and I didn't see the purpose of just having bulbs that light up for no reason?
Did a search on the fiber optic spider-looks like that's my problem. Ill get the bulbs replaced and hope that fixes my problem!
__________________
1982 240D - 251,000 miles (all parts pulled and for sale, body crushed )
1983 240D 4 speed manual - 233,000 miles
2001 Ford Ranger XLT 4WD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page