Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-03-2009, 11:10 PM
Registered User
 
Join Date: Sep 2004
Location: Houston, TX
Posts: 106
Question Strange lights on dashboard

Folks, Yesterday the three lights at the bottom right hand side of the dashboard began to light up. on my 1983 300D Turbodiesel. These are both brake lights and the alternator light. I drove it, got home, and tested the battery and charging system with a meter from Harbor freight, and it indicated that the battery was charging, as I thought it might be the alternator going out.
This evening, I drove the car after dark, and noticed that not only do these 3 lights stay on, but also the low fuel light (yellow triangle) light also stays on all the time, the tank is more than 3/4 full so I know that is not the problem.
Does anyone know where to look to start diagnosing this problem? It is almost as though some ground loosened up or something, as I don't believe there is anything wrong with the brakes, the tank has plenty of gasoline, and the battery and alternator appear to be fine, so it appears as though these lights on the dashboard are connected to something that has loosened up or something.
Any help is greatly appreciated, thanks so much in advance!

__________________
1983 300D (Hans)
Reply With Quote
  #2  
Old 08-03-2009, 11:19 PM
tbomachines's Avatar
ಠ_ಠ
 
Join Date: Mar 2009
Location: Philadelphia
Posts: 7,018
It sounds like a ground for me. The fuel sender reserve light comes on when the little wire inside the unit becomes ungrounded IIRC, which supports that diagnosis. However I'd imagine that would happen at the unit rather than the dash....Pull the cluster out and check out any loose wires, make sure they're all in there nice and snug.
__________________
TC
Current stable:
- 2004 Mazda RALLYWANKEL
- 2007 Saturn sky redline
- 2004 Explorer...under surgery.

Past: 135i, GTI, 300E, 300SD, 300SD, Stealth
Reply With Quote
  #3  
Old 08-08-2009, 12:00 PM
Registered User
 
Join Date: Sep 2004
Location: Houston, TX
Posts: 106
It appears as though the alternator isn't putting out enough voltage. Only ~ 11 volts, so I will need to replace the alternator. Thanks for your help, and if you have any recommendations as to which alternator to use, I'd appreciate if you'd share it with me, thanks!
__________________
1983 300D (Hans)

Last edited by rfdillon; 08-08-2009 at 12:19 PM.
Reply With Quote
  #4  
Old 08-08-2009, 12:22 PM
Jeremy5848's Avatar
Registered Biodiesel User
 
Join Date: Mar 2006
Location: Sonoma Wine Country
Posts: 8,401
It may simply be that the brushes in the alternator are worn down to where they no longer make good contact. The brushes are part of the regulator which is separably replaceable for about $40 and you can buy one from FastLane right here on the forum (they support this forum).
__________________

"Buster" in the '95

Our all-Diesel family
1996 E300D (W210) . .338,000 miles Wife's car
2005 E320 CDI . . 113,000 miles My car
Santa Rosa population 176,762 (2022)
Total. . . . . . . . . . . . 627,762
"Oh lord won't you buy me a Mercedes Benz."
-- Janis Joplin, October 1, 1970
Reply With Quote
  #5  
Old 08-08-2009, 04:12 PM
Registered User
 
Join Date: Sep 2004
Location: Houston, TX
Posts: 106
Thanks for the suggestion, but I had an old regulator that still had good brushes in it and I put that in the alternator, and it still is only putting out ~ 11 volts.
__________________
1983 300D (Hans)
Reply With Quote
  #6  
Old 08-08-2009, 05:03 PM
Jeremy5848's Avatar
Registered Biodiesel User
 
Join Date: Mar 2006
Location: Sonoma Wine Country
Posts: 8,401
If it is not the brushes/regulator, and if there isn't a rogue load such as a stuck-on preglow relay, then the alternator itself is the next suspect. A bad diode in the diode array could cause the symptoms you are seeing. Note: most alternator sales are based upon you turning in your old alternator as a "core." When you do so, make sure you keep the best regulator, don't give it away in the core. In fact, I don't know if rebuilt alrernators even come with the regulator or is that a separate purchase? Can we hear from someone who has been there before?
__________________

"Buster" in the '95

Our all-Diesel family
1996 E300D (W210) . .338,000 miles Wife's car
2005 E320 CDI . . 113,000 miles My car
Santa Rosa population 176,762 (2022)
Total. . . . . . . . . . . . 627,762
"Oh lord won't you buy me a Mercedes Benz."
-- Janis Joplin, October 1, 1970
Reply With Quote
  #7  
Old 09-08-2011, 10:13 AM
1978 300D, Georga car
 
Join Date: Dec 2010
Posts: 208
I am reviving this thread because my 78 300D is not charging, or is only charging only a litttle. I get 12 volts with a recharged battery (3 months old). Start the car, same voltage. Load it up, same voltage. Should I expect to see an increase in voltage of about 2 volts when running? How can I isolate the problem between the alternator and the starter?

Thanks
Reply With Quote
  #8  
Old 09-08-2011, 10:51 AM
Registered User
 
Join Date: Jan 2002
Posts: 18,350
Quote:
Originally Posted by supercub View Post
I am reviving this thread because my 78 300D is not charging, or is only charging only a litttle. I get 12 volts with a recharged battery (3 months old). Start the car, same voltage. Load it up, same voltage. Should I expect to see an increase in voltage of about 2 volts when running? How can I isolate the problem between the alternator and the starter?

Thanks
Yes. Not sure how the starter figures into the equation. Replace the regulator and report back.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #9  
Old 09-08-2011, 12:16 PM
1978 300D, Georga car
 
Join Date: Dec 2010
Posts: 208
Yes, correction: regulator.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page