Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-12-2009, 08:18 PM
Registered User
 
Join Date: Jan 2009
Posts: 7
Question Need Cruise Control for 1979 300D

We have the complete cruise hooked up but the BLUE wire. It does not work. Again we are talking about adding this cruise to a 79 300D Mercedes that did not come with factory cruise. (Grey Market car from Germany) We used the Audiovox CCS-100. Just like you said. Help please?

Last edited by Same Dude; 09-22-2009 at 08:45 PM. Reason: Have cruise need extra help with install
Reply With Quote
  #2  
Old 09-12-2009, 09:46 PM
Registered User
 
Join Date: Jun 2009
Location: Milford, Nebraska
Posts: 34
I installed an Audiovox cruise control system on my 85 300cd and it was the best $110 I've spent. I've replaced the factory cc amp several times, and could only get a year or so before the cruise was unreliable again.

There's a thread on here that gives EXCELLENT step by step directions to install it, and even how to use the factory switch so it looks correct. It took me the better part of a day to install it, but I really was in no hurry.

Napa used to handle this sytem, but can no longer get it. I found it from O'reilly Auto Parts for $130, Advance Auto Parts for $110, and I believe JC Whitney has the same unit as well.

The author of the instructions on this forum recommended that an additional vacuum canister be installed, however being somewhat "cheap" I didn't order one, and the system still works absolutely perfect.

The cruise on my '93 works only marginal, and I'll be installing this same Audiovox system on it. I'm not spending any more time or $$ on the factory system- not when I can by a brand new complete depandable setup for about 1/3 of what an MB rebuilt amp costs!

Good luck!
Russ
Reply With Quote
  #3  
Old 09-12-2009, 11:01 PM
Registered User
 
Join Date: Oct 2006
Location: Jasper,AL
Posts: 89
The Official Audiovox CCS-100 Install Thread

You're welcome.
__________________
Mike
1983 Mercedes-Benz 300SD 270K
1960 Ford F250 62K
1990 Mazda Miata 156k

The thing is Bob, it's not that I'm lazy, it's that I just don't care.
Reply With Quote
  #4  
Old 09-12-2009, 11:18 PM
Registered User
 
Join Date: Jan 2009
Posts: 7
Are you sure this audiovox system will work on my 1979 300D. This car does not have cruise on it.
Reply With Quote
  #5  
Old 09-13-2009, 12:10 PM
Registered User
 
Join Date: Jun 2009
Location: Milford, Nebraska
Posts: 34
Yes, it is a complete kit, so if you don't already have a switch, it comes with one that you can mount on the dash. Everything else is included as well, including a speed sensor that you attach to the driveshaft, all linkage, brackets, etc.
Reply With Quote
  #6  
Old 09-22-2009, 08:39 PM
Registered User
 
Join Date: Jan 2009
Posts: 7
We have the complete cruise hooked up but the BLUE wire. It does not work. Again we are talking about adding this cruise to a 79 300D Mercedes that did not come with factory cruise. (Grey Market car from Germany) We used the Audiovox CCS-100. Just like you said. Help please?
Reply With Quote
  #7  
Old 09-23-2009, 10:05 AM
Registered User
 
Join Date: Jun 2009
Location: Milford, Nebraska
Posts: 34
I didn't use the blue wire either, and mine works just fine.

Since your car didn't have factory cruise, I assume you used the switch that came with the kit? I believe it has a green light on it that will show when/if the power is on. Does your green light come on?

I guess a couple of things I'd check would be the brake switch (make sure it's not cancelling the cruise) and the speed sensor (make sure it's got the correct gap between the magnets and sensor).

Outside of that, just recheck every connection, make sure you have good vacuum, the linkage is hooked up to where it pulls straight, etc.

Was there a phone-help number in the Audiovox box? It seems like they do offer troubleshooting assistance.

Good Luck!
Russ
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page