Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2009, 06:01 PM
Registered User
 
Join Date: May 2009
Location: Hamburg, NY
Posts: 145
no glow, what now?

Got in Serenity this morning, turned the key, and no glow plug light.... Thinking maybe just the bulb in the cluster blew I went to start after the usual amount of time, after cranking for far too long she started. Apparently the plugs or relay aren't workin'. What should I check first?
__________________
Serenity-86' 300SDL 482,000 miles (on a "14" head!)
Reply With Quote
  #2  
Old 10-28-2009, 06:13 PM
snookwhaler's Avatar
Linesider
 
Join Date: Feb 2009
Location: Treasure Coast, FL
Posts: 1,417
Here is a link to a bunch of glow threads from the "Resources" section at the top of the page.

http://www.peachparts.com/shopforum/diesel-discussion/137732-glow-plugs-link-thread.html#post1019018


I just fixed a glow plug problem with mine. Luckily it was easy. Basically you get a meter and check the plugs, relay, fuses and wiring. On the 6 cyl. they can be a pain because of the intake.
__________________
AJ

1985 300D (SOLD)

Reply With Quote
  #3  
Old 10-28-2009, 06:54 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Quote:
Originally Posted by djustin973 View Post
What should I check first?
The 80A fuse under the cover of the relay.
Reply With Quote
  #4  
Old 10-29-2009, 02:03 AM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 27,387
If the Bulb is OK it will light up with the rest of you Instrument Cluster warning Lights when you first turn the Ignition key.

As Brian said do a visual check of the Fuse.
Below is a pic of my 80amp Fuse that cracked. You may need to take a really had look at it. The first time I looked I did not notice it.
Attached Thumbnails
no glow, what now?-zzzzzzzzzzz.jpg  
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #5  
Old 10-29-2009, 08:37 AM
Registered User
 
Join Date: Apr 2009
Location: Sunsites, AZ
Posts: 692
Quote:
Originally Posted by Diesel911 View Post
If the Bulb is OK it will light up with the rest of you Instrument Cluster warning Lights when you first turn the Ignition key.

As Brian said do a visual check of the Fuse.
Below is a pic of my 80amp Fuse that cracked. You may need to take a really had look at it. The first time I looked I did not notice it.
Put a meter on it and see if juice goes through . . . sometimes on a small hairline crack it only acts up once it heats up . . . so turn on to glow position, and check.
__________________
82 240D Manual 277K and still rolling!
02 Volvo S60 AWD For Sale
Reply With Quote
  #6  
Old 10-29-2009, 08:49 PM
Registered User
 
Join Date: May 2009
Location: Hamburg, NY
Posts: 145
Checked the fuse, it was fine. Figured the next step was just switch out the whole relay, All fixed! something in the relay must have konked out. Anyone seen a cause of relays failing outside the relay itself? I'd hate to have some other problem I'm not seeing cook this relay too.
__________________
Serenity-86' 300SDL 482,000 miles (on a "14" head!)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page