Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2009, 11:23 AM
Registered User
 
Join Date: Dec 2005
Posts: 2,275
Proper radiator flow

Recently flushing my 300cd radiator and noticed the reserve tank hasnt been getting hot or pressure .Clogged radiator? Ive taken the incoming hose off the top of the radiator while cold starting and its flow is good as the engine warms up,just no heat at the reserve.
Reply With Quote
  #2  
Old 11-17-2009, 11:33 AM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
What year car? Have you replaced the expansion tank cap?
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
  #3  
Old 11-17-2009, 11:51 AM
Registered User
 
Join Date: Dec 2005
Posts: 2,275
1984 300cd ,it stays cold.
Reply With Quote
  #4  
Old 11-17-2009, 12:31 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
Have you checked the t-stat? Like is it missing or stuck open? What about the engine temp?
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
  #5  
Old 11-18-2009, 10:48 AM
Registered User
 
Join Date: Dec 2005
Posts: 2,275
The engine temp is ok ,180 ,it seems that no pressures building but have plenty of flow at the top hose.My 78 i sold had similiar problems ,that one was a massive radiator failure,clogged and unfixable by my radiator guy.It looks like Im heading off to the radiator shop with this one.
Reply With Quote
  #6  
Old 11-18-2009, 10:50 PM
Registered User
 
Join Date: Oct 2007
Location: St. Thomas PA
Posts: 957
On my '83, the expansion tank stays cool also. The only flow to it is the small hose off the top of the radiator. Lack of pressure would point to a radiator cap.
Reply With Quote
  #7  
Old 11-19-2009, 06:21 AM
t walgamuth's Avatar
dieselarchitect
 
Join Date: Apr 2005
Location: Lafayette Indiana
Posts: 32,822
If your temp guage reads normal forget it. The expansion tank on the turbo models is out of the stream. It will only get heat from the direct transmission of heat through the coolant as it does not circulate to it...
__________________
[SIGPIC] Diesel loving autocrossing grandpa Architect. 08 Dodge 3/4 ton with Cummins & six speed; I have had about 35 benzes. I have a 39 Studebaker Coupe Express pickup in which I have had installed a 617 turbo and a five speed manual. It still needs upholstery redone...I also have a 427 Cobra replica with an aluminum chassis.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page