Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2010, 04:28 AM
Racerx
 
Join Date: Jan 2007
Location: Massachusetts
Posts: 69
Help with climate control

I am having electrical problems with my climate control. It worked fine until I gave the car to my daughter, ("then it just stopped working"). The fuse keeps blowing on it. I unplugged the climate control plugs (removed the load) and it keeps blowing the fuse when the ignition is turned on. I believe that would indicate a short somewhere in the wiring between the fuse box and the climate control. I don't have an electrical print of this, if anyone has this or has any ideas of a solution, I would really appreciate the help.
1984 300 sd

Thanks Dan
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page