Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2010, 11:20 AM
Registered User
 
Join Date: May 2006
Location: Seattle
Posts: 136
I've got three cars and none of them work....

....well, that's a bit of an exaggeration but:
- my '79's in the shop getting the heating system fixed
- the '87 has a dead battery and a shot steering gear box
- my '85 brakes just started acting up.

When it rains it pours I guess.

I'll take the wheels off of my '85 tonight to see what's going on but maybe someone can tell me what this might be: suddenly the brakes turned rock hard...it really take a great deal of pressure to stop the car. Does this sound familiar? I can't recall it ever happening on any car that's I've had.

I'm estimating the pads to be down to about 20% but I've got to take the wheels off to be sure.

Thanks -Harv

Reply With Quote
  #2  
Old 01-11-2010, 11:26 AM
helpplease
Guest
 
Posts: n/a
Is this when the car is just started or after driving for a while? Is the pedal really rock hard or is the pedal soft and goes to the floor easily?
Reply With Quote
  #3  
Old 01-11-2010, 11:28 AM
Registered User
 
Join Date: Jan 2006
Location: Tucson, AZ
Posts: 4,624
Check the vacuum pump on the '85.
Reply With Quote
  #4  
Old 01-11-2010, 11:37 AM
Registered User
 
Join Date: Sep 2006
Location: Middle TN
Posts: 3,652
Quote:
Originally Posted by Mike D View Post
Check the vacuum pump on the '85.
and the brake booster if vacuum is good.
__________________
85SD 240K & stopped counting. 84SD 180,000. Thinking of painting both.
Reply With Quote
  #5  
Old 01-11-2010, 11:41 AM
muleears's Avatar
Old MB Driver
 
Join Date: May 2006
Location: Windsor, VA
Posts: 1,435
I know what you mean, my 98 is getting GP's replaced (what a nightmare) the 87 wouldn't start because of the cold and two dead GP's, the 85 has bad glow plugs and bad steering box and the Prius I left on last night after changing a headlight bulb. 4, and non of them driveable... Oh well , thanks to AAA I got the Prius and the 87 going, so off to work I go....
__________________

Muleears
'07 E320 Bluetec 133K my DD
'04 Jaguar XJ8 VDP, 34K
'10 Hyundai Accent 60K Grocery Getter
'02 VW Golf soon to be on the road again
'97 E300 Diesel Son's DD
'61 VERY tolerant wife

Hampton Roads, VA USA

Gone but not forgotten:
'67 250S 95K
'86 300SDL
'87 300D Turbo, 364K! R.I.P.
'98 E300 Turbodiesel, 213K
'02 S420, 164K
'01 Prius 138K
Reply With Quote
  #6  
Old 01-11-2010, 12:20 PM
daw_two's Avatar
diesel enthusiast
 
Join Date: Jan 2007
Location: Germantown, TN
Posts: 5,438
just buy (another) backup car
Here's one that I bought that starts now:
Latest Purchase ---- 1980 Gold 300D

__________________
daw_two
Germantown, TN

Links:
Current Car --- 05/2012 1984 300D Light Ivory, Red interior
Cluster Needles Paint
New Old Stock (NOS) parts

Past:
3/2008 1986 300SDL "Coda"
04/2010 1965 190D(c) "Ben"
& many more
Reply With Quote
  #7  
Old 01-11-2010, 12:59 PM
okyoureabeast's Avatar
Rogue T Tolerant
 
Join Date: Jul 2009
Location: North America
Posts: 1,644
*3 on the break booster as well as the vacuum leading up to it.
__________________
-Typos courtesy of my mobile phone.
Reply With Quote
  #8  
Old 01-11-2010, 11:25 PM
Registered User
 
Join Date: May 2006
Location: Seattle
Posts: 136
Yeah, it looks like it is vacuum related as I just realized the door locks stopped working properly and the car is shifting kind of funny. -harv
Reply With Quote
  #9  
Old 01-11-2010, 11:35 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,355
Could be as simple as a broken main vacuum line feeding the brake booster. Could be as painful as a bad vacuum pump or bad brake booster.
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #10  
Old 01-15-2010, 03:33 PM
Registered User
 
Join Date: May 2006
Location: Seattle
Posts: 136
In the end, this was a shot vacuum pump.....all fixed now and the car has returned to behaving normal. thx -harv

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page