Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2010, 11:47 AM
Registered User
 
Join Date: Dec 2005
Location: The Bay Area via Phoenix, Chicago and Minnesota.
Posts: 374
606 starts COLD fast and perfect, smokes and misses till warm

95-E300 283K (606.910) with new injectors 40K back. All glow plugs working.

Sub 40 temps, the colder the longer the smoke and missing issue.

Engine starts ice COLD instantly always no matter the temp and runs perfect at idle for with no smoke or detonation for the first 3-5minutes. If allowed to idle till warm, it will go through a period of smoking and missing. If driven immediately, it smokes and misses until about 60c of coolant temp. Once it clears, all is normal, no smoke, excellent acceleration.

Fuel has been "turned" repeatedly and filters are clean.

No external fuel leaks.

No oil consumption what so ever in the 6 years I've had the car, winter oil is right now is Valvoline Blue Synthetic 5W40.


Areas of possible issue:
Pump advance for cold start is not working?
Funky injector or two?
ADA?
Distribution valves?

__________________
Mark
========
THE WHITE FLEET
2016 GLE300d 4-MATIC 38K BROWN!
2012 S350 Bluetec==93k WHITE
2007 ML320 CDI==166K WHITE (FOR SALE)
2005 E320 CDI--140K--WHITE


Under new management:
1995 E300-Diesel-133.5K--THE CAR IS BLUE
1986 300SL--97.5K (European) AND WHITE. Back in Europe!
1991 190E 2.3-73K California Perfect.--WHITE
1995 E320-Wagon-159K--WHITE (recently scrapped)
1987 300D Turbo-213K--WHITE
1987 190D 2.5 Turbo-288K--WHITE

Last edited by markg612; 01-18-2010 at 03:22 PM.
Reply With Quote
  #2  
Old 01-15-2010, 11:52 AM
scottmcphee's Avatar
1987 w124 300D
 
Join Date: Mar 2008
Location: Edmonton, Canada
Posts: 1,539
Check the injectors for good spray pattern and pop pressure.

I had similar issue in my 603 with a pissing injector in the mix. Once up to temp, it's amazing how the engine masked the injector sending a straight stream of diesel into prechamber, rather than a mist. But takes good heat in the combustion chamber to get there.

New nozzles, all set right, and stumble went away.
__________________
Cheers!
Scott McPhee

1987 300D
Reply With Quote
  #3  
Old 01-15-2010, 11:54 AM
Registered User
 
Join Date: Dec 2005
Location: The Bay Area via Phoenix, Chicago and Minnesota.
Posts: 374
That's what my first thought is--I'm fighting the age of the injectors in going there first.
__________________
Mark
========
THE WHITE FLEET
2016 GLE300d 4-MATIC 38K BROWN!
2012 S350 Bluetec==93k WHITE
2007 ML320 CDI==166K WHITE (FOR SALE)
2005 E320 CDI--140K--WHITE


Under new management:
1995 E300-Diesel-133.5K--THE CAR IS BLUE
1986 300SL--97.5K (European) AND WHITE. Back in Europe!
1991 190E 2.3-73K California Perfect.--WHITE
1995 E320-Wagon-159K--WHITE (recently scrapped)
1987 300D Turbo-213K--WHITE
1987 190D 2.5 Turbo-288K--WHITE
Reply With Quote
  #4  
Old 01-15-2010, 12:00 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
My '95 does EXACTLY the same thing, to a tee. Can't wait to find out what fixes yours.
Subscribed to thread.......
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #5  
Old 01-15-2010, 01:50 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
Lots of blue/white smoke, knocking, sputtering until warm = classic bad glow plug... Now, I understand yours check out good but I have had plugs check good but they aren't really doing anything.
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #6  
Old 01-15-2010, 01:53 PM
Registered User
 
Join Date: Dec 2005
Location: The Bay Area via Phoenix, Chicago and Minnesota.
Posts: 374
Thanks Evan, Glow plugs are all good and tested--Starts and runs perfect for 3-5 minutes, long after glow cycle is complete.
__________________
Mark
========
THE WHITE FLEET
2016 GLE300d 4-MATIC 38K BROWN!
2012 S350 Bluetec==93k WHITE
2007 ML320 CDI==166K WHITE (FOR SALE)
2005 E320 CDI--140K--WHITE


Under new management:
1995 E300-Diesel-133.5K--THE CAR IS BLUE
1986 300SL--97.5K (European) AND WHITE. Back in Europe!
1991 190E 2.3-73K California Perfect.--WHITE
1995 E320-Wagon-159K--WHITE (recently scrapped)
1987 300D Turbo-213K--WHITE
1987 190D 2.5 Turbo-288K--WHITE
Reply With Quote
  #7  
Old 01-15-2010, 01:58 PM
Registered User
 
Join Date: Jul 2003
Location: Northern Virginia
Posts: 1,073
injector x 2

Good luck with the injectors. Bosio nozzles are hard to find - I haven't been able to locate them anywhere and Monark doesn't make a nozzle for the 606 injectors in the 95.

About 5k miles ago, I purchased india rebuilt bosch. Immediately and dramatically improved performance. For the first 2k miles, they were silent. Now they make as much noise at 65mph as the original MB injectors did after 235k miles. Junk!

I kept the original MB injectors in case Bosio nozzles come available. I read all of the threads here and knew going into it that the india rebuilts were junk, but I was having serious acceleration issues and couldn't get it to go faster than 65mph.

Let us know if you find a source for Bosios for the 606. I'd be on it in a minute.
__________________
2009 E320 Bluetec 117,000
1995 E300D 306,000 sold
1996 Ford Taurus LX 130,000 Sold
1985 300TD Still 225,000
2016 Ford Fusion 24,900
Reply With Quote
  #8  
Old 01-15-2010, 04:36 PM
Registered User
 
Join Date: Apr 2006
Location: North Shore, MA
Posts: 200
dieselgiant.com has the Bosio's for the OM606 - I am assuming same nozzles for the turbo and non-turbos, just different pop pressures?
__________________
Scott C.

2006 E320 CDI (120k miles)
FOR SALE: 1998 E300 Turbo Diesel - Black w/Tan Leather - Euro delivery (236k miles)
Reply With Quote
  #9  
Old 01-15-2010, 04:57 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
Quote:
Originally Posted by markg612 View Post
Thanks Evan, Glow plugs are all good and tested--Starts and runs perfect for 3-5 minutes, long after glow cycle is complete.
Sorry, I took that to mean that it starts perfect when warm.
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #10  
Old 01-15-2010, 04:57 PM
dagObx's Avatar
Registered User
 
Join Date: Jan 2008
Location: Outer Banks, NC
Posts: 382
Quote:
Originally Posted by KarTek View Post
Lots of blue/white smoke, knocking, sputtering until warm = classic bad glow plug... Now, I understand yours check out good but I have had plugs check good but they aren't really doing anything.
^^ what he said!
Reply With Quote
  #11  
Old 01-15-2010, 05:41 PM
Registered User
 
Join Date: Jul 2003
Location: Northern Virginia
Posts: 1,073
bosio

No. Dieselgiant can't get them.
__________________
2009 E320 Bluetec 117,000
1995 E300D 306,000 sold
1996 Ford Taurus LX 130,000 Sold
1985 300TD Still 225,000
2016 Ford Fusion 24,900
Reply With Quote
  #12  
Old 01-15-2010, 07:02 PM
Registered User
 
Join Date: Nov 2008
Location: Annapolis, MD
Posts: 164
Darn, my 616's doing basically the same thing (and I suspect injectors), I'm just trying to squeeze pennies no this <$1000 car...now i feel lucky to have plentiful injector sources!
__________________
05 E320 CDI
86 300D Euro Auto
74 914 2.0, carb'd, flared
94 F-250 I6

82 240D SOLD
83 240D Euro 4spd SOLD
Reply With Quote
  #13  
Old 01-18-2010, 01:34 PM
Registered User
 
Join Date: Nov 2007
Location: Chi-Town
Posts: 100
cold start-smoke

My 95 E300D has begun exhibiting the exact issues when started cold (below 30). My local diesel guy (works on mb diesels almost exclusively) blames the smoke and missing on bad diesel fuel. He wants me to add 2 gallons of kerosene to my 3/4 full tank, and take it up to highway speeds for 1/2-1 hour to try to clean out the injectors.

He told me to stick to name brand diesel from Shell or Mobil here in Chicago.

Any thoughts on all this advise?
Reply With Quote
  #14  
Old 01-18-2010, 03:06 PM
Registered User
 
Join Date: Dec 2005
Location: The Bay Area via Phoenix, Chicago and Minnesota.
Posts: 374
I'll let you know on the injectors, I'm mid pull as I type--I'm sending to Bosch down to:

Magiera Diesel Injection Service, Inc.
1145 E. Summit St.
Crown Point, IN 46307
Phone: 219-663-7286
Fax: 219-663-7713

They'll turn them in a day $25 each full overhaul to spec--$51 each if they need a nozzle.

re fuel, i've had fits with crap diesel here in chicago. Shell, and mobil both suck, I've been buying with good success from KwiK stops out in the burbs. in the city, it's all been junk, especially BP and Shell. I don't think they turn much fuel. There's a place on Cicero south of Ogdon on the east side of the street I've had excellent luck as of late, lots of truck in and out, which is lots of turn.
__________________
Mark
========
THE WHITE FLEET
2016 GLE300d 4-MATIC 38K BROWN!
2012 S350 Bluetec==93k WHITE
2007 ML320 CDI==166K WHITE (FOR SALE)
2005 E320 CDI--140K--WHITE


Under new management:
1995 E300-Diesel-133.5K--THE CAR IS BLUE
1986 300SL--97.5K (European) AND WHITE. Back in Europe!
1991 190E 2.3-73K California Perfect.--WHITE
1995 E320-Wagon-159K--WHITE (recently scrapped)
1987 300D Turbo-213K--WHITE
1987 190D 2.5 Turbo-288K--WHITE
Reply With Quote
  #15  
Old 01-18-2010, 03:16 PM
Registered User
 
Join Date: Dec 2005
Location: The Bay Area via Phoenix, Chicago and Minnesota.
Posts: 374
Quote:
Originally Posted by dagObx View Post
^^ what he said!
Thx, glow plugs tested repeatedly perfect, car starts smooth and perfect, missing occurs beyond after-glow is over and before +60C coolant temp.

__________________
Mark
========
THE WHITE FLEET
2016 GLE300d 4-MATIC 38K BROWN!
2012 S350 Bluetec==93k WHITE
2007 ML320 CDI==166K WHITE (FOR SALE)
2005 E320 CDI--140K--WHITE


Under new management:
1995 E300-Diesel-133.5K--THE CAR IS BLUE
1986 300SL--97.5K (European) AND WHITE. Back in Europe!
1991 190E 2.3-73K California Perfect.--WHITE
1995 E320-Wagon-159K--WHITE (recently scrapped)
1987 300D Turbo-213K--WHITE
1987 190D 2.5 Turbo-288K--WHITE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page