Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 03-19-2010, 10:02 AM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,179
Quote:
Originally Posted by Mbenzo300td View Post
Im too much of a women to go try anything tonight, im still in shock about possibly ruining a blue printed and balanced engine with only 8863 on the clock. But ill most likely end up disconnecting my intercooler piping so i can block it at the manifold. Then do as the write up says and as i should have done and remove the vacuum pod and make sure the sov is in place.
this type of overspeed is unlikely to have ruined the motor.
the IP has a governor to prevent total redline RPM overspeed, so while it's not a good thing, it is unlikely any serious damage was done.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #17  
Old 03-19-2010, 01:43 PM
Mbenzo300td
 
Join Date: Dec 2004
Location: Redmond, WA
Posts: 38
Yes those are pics of my car with intercooler piping. What worried me most is seeing sparks coming from the hotside. I dont know if they were from the turbo or straigt from the exhaust ports. also ive got a little puddle of oil sitting on top of my water pump. most likely from the front cover or belt tensioner arm. I now wonder if ive created a leak.
__________________
87 w124 om603
Reply With Quote
  #18  
Old 03-19-2010, 06:12 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
The sparks were probably just carbon bits burning off. Doubtful any harm was done.
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #19  
Old 03-19-2010, 11:04 PM
Mbenzo300td
 
Join Date: Dec 2004
Location: Redmond, WA
Posts: 38
Took out the vacuum pod tosday and put it all back together correctly. Car still wants to go to WOT and shut off wont shut it down. although it is working properly. When the key shuts off the lever falls. Any ideas?
__________________
87 w124 om603
Reply With Quote
  #20  
Old 03-19-2010, 11:12 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,179
did you call Roy?
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #21  
Old 03-19-2010, 11:21 PM
Mbenzo300td
 
Join Date: Dec 2004
Location: Redmond, WA
Posts: 38
I havent. however i did talk to a master mb tech and he assured me putting it together properly would do the trick. do you think roy is still up?
__________________
87 w124 om603
Reply With Quote
  #22  
Old 03-20-2010, 06:25 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
Smoke and Mirrors

You may have to VISUALLY "See" the operating rod of the Vacuum Shutoff
slide onto the Manual Shutoff (Inside the the pump).

The Acid Test USED to be:
"If you put a Mighty Vac to the Vacuum Shutoff AND the Manual OFF lever
moved... All's Good."

From what you're saying the emergency OFF lever moves (As if it were connected,properly) But the IP still "Makes Turns" for 12,000 RPM...

Almost sounds like you've lost the Physical connection (internally) between the Lever and "Zomezing" [your IP Governor (?) ]
(Hope Not)

EDIT: according to the schematic the part 2r is the ACTUAL lever that pushes
against the Governor and shuts off the engine. So, your connection between
"6" and 2r is good (The Vacuum shutoff works).
The Governor is not limiting the RPMs as it should.
[Gawd, I sound like I know WT* I'm talking about,don't I?]
I prognosticate that some how you've disconnected something between the
OFF lever shaft and the Governor???


Somewhere I've seen a really good diagram of the internals of the IP
(Dummy ,Just can't seem to locate it,Now)

here's some from GSXR's "website":
Attached Thumbnails
Emergency!!-screenhunter_03-mar.-20-06.54.jpg   Emergency!!-screenhunter_05-mar.-20-06.59.jpg  
__________________
'84 300SD sold
124.128

Last edited by compress ignite; 03-20-2010 at 07:25 AM.
Reply With Quote
  #23  
Old 03-20-2010, 07:06 AM
Registered User
 
Join Date: May 2003
Location: Boonville Indiana
Posts: 2,342
Idle Solenoid

I have a 1987-300D and the engine dies at about 1000-1100 rpms. It runs like a clock above 1100 and will cruise all day and night at 70-80 mph. Will no longer start but will run if pushed at about 30-35mph. I wonder about the Idle Solenoid and until I read your article(great piece of work) didn't know that the engine had a Idle Solenoid. Any tests to check the solenoid and what exactly does the solenoid do and why is it needed? Jim
__________________
James A. Harris
Reply With Quote
  #24  
Old 03-20-2010, 07:29 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
No Idle

Jim,

Here Ya Go:

http://www.ps2cho.net/downloads/MB%20CD/W124/w124CD1/Program/Engine/602_603/07.1-2006.pdf

However, the quick "down and dirty" is to unplug the electrical connector to
Y22. EXCEPT your's will die @ Idle.

I (? THINK ?) (?Sometimes?) believe the electronic Idle control is to keep the engine from shutting off when the AC compressor kicks in at idle.

The "Mechanical Idle" is set with the screw (with/without plastic knob) in the
Pictogram.(As you can see it's right in front of theY22 on the I.P.)

BEFORE you do ANYTHING mechanical to your IP find the referred to
"Resistance Trimming Plug" and see if that's not the problem.
http://www.ps2cho.net/downloads/MB%20CD/W124/w124CD1/Program/Engine/602_603/07.1-2053.pdf

[I don't know where this RTP is ]
So,It looks like you've got THREE Idle controls...
1.The electronic (Y22)
2.The Mechanical set screw on the back of the IP.
3. and the Trimming Plug.

1100 RPMs thatsa mighty lotta revolutions.

I've a feeling that ZOMEZING else is the cause of your woes.
MAYBE
1. Fuel Tank Screen and Filters (? How Long Since cleaned ?)
2. The Dreaded Fuel Pressure Relief Valve Spring (Starboard Side of IP)
It's a "Banjo Bolt" with a spring loaded valve inside.
3. You have the Surgically Clean Air Filter ,No?
4. Lift Pump Woes?
5. Sneaky, Rat Bastard air leak somewhere in the Fuel system between the
lift pump and the Tank?

I'm throwing Pasta at the wall here.

Diesel = s "Big Air Pump"
NEEDS: Air ,Fuel,COMPRESSION (all three = s Go,Go,Go)

as always,thanks
Let us know what it is if you will. (Learning Curve)

EDIT:
Just for grins and giggles,look around about your Left hand side Motor Mount
and see if you have one of those silly "Fuel Thermostats" (Pre-Heater)
the rubber O-Ring on them gets old and leaks fuel.AND ,If it can leak fuel
It can suck Air.

There's no way your Timing could be so out that it's the problem?
(How Old's your Chain?)
Attached Thumbnails
Emergency!!-screenhunter_07-mar.-20-07.32.gif   Emergency!!-screenhunter_08-mar.-20-07.38.gif  
__________________
'84 300SD sold
124.128

Last edited by compress ignite; 03-20-2010 at 10:59 AM.
Reply With Quote
  #25  
Old 03-20-2010, 11:59 PM
Mbenzo300td
 
Join Date: Dec 2004
Location: Redmond, WA
Posts: 38
No luck. Nothing I can see it out of place. I hope I dont have to pull this ip. I was beggining to think it was left over fuel that was causing it to go crazy, but I realize thats not possible.
__________________
87 w124 om603
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page