PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   Instrument lights mystery (http://www.peachparts.com/shopforum/diesel-discussion/273881-instrument-lights-mystery.html)

JWJ 03-20-2010 06:13 PM

Instrument lights mystery
 
The instrument cluster night lights in the '85 300TD stopped working a few months ago. The bottom row of status lights work fine.

I've replaced the bulbs, replaced the rheostat, soldered the leads on the rheostat, and checked the fuses. Still no lights.

Are there any other possible causes?

Pili380SL 03-20-2010 07:20 PM

I imagine you've checked for 12v at the pin on the cluster connector....I'd start tracing on the circuit board and see where you're losing voltage. Do not just check for continuity...high resisitance will show continuity but not allow enough voltage to light the bulbs.

BAd124 05-09-2010 01:36 PM

For what its worth I just had a similar issue on my 300E. The gauge lights worked fine but the rest of the dash, center console and rear window switches were out. Turned out to be a small rectangular looking fuse on the back of the cluster. Mine was indicated by a red plug


All times are GMT -4. The time now is 02:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website