Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-22-2010, 11:42 PM
Diesel Pusher
 
Join Date: Nov 2007
Location: Washington NC
Posts: 110
Really Need to Get Turn Signals Working

I am really trying to get my 1985 300TD back on the road after the PO let her sit for almost 4 years.

Well when I first got the car the turn signals worked fine. Replaced the battery and now they do not work at all. I searched and found info on the relay under the console in front of the shifter. I replaced that with one out of a parts car,which I have no clue if the signals worked in that car, and it did not work either.

I have no Owners Manual or fuse card in the fuse box lid. Which number fuse can I check?? NO burn fuses that I can see in the holders
Anything else I need to check/look into??

Wipers and High beam both work on the stalk
Front and rear lights also work.....

Please I just don't know the car well enough to know where to check

__________________
On the hunt...
1985 300D----Sold
1985 300TD---Sold
1983 300SD---Sold
Reply With Quote
  #2  
Old 04-22-2010, 11:53 PM
johnathan1's Avatar
Registered User
 
Join Date: Feb 2008
Location: Downey, SoCal
Posts: 1,190
Do your hazards work?
__________________
Current cars:
2000 ML55 AMG, 174k miles
2003 C240 T-Modell, 202k miles
1995 S320, 207k Miles
Reply With Quote
  #3  
Old 04-23-2010, 12:00 AM
Diesel Pusher
 
Join Date: Nov 2007
Location: Washington NC
Posts: 110
Quote:
Originally Posted by johnathan1 View Post
Do your hazards work?
Nope
__________________
On the hunt...
1985 300D----Sold
1985 300TD---Sold
1983 300SD---Sold
Reply With Quote
  #4  
Old 04-23-2010, 09:07 AM
Registered User
 
Join Date: Apr 2010
Location: Charleston, SC
Posts: 84
If the hazard switch is bad, none of the turn signals will work so you may want to check that out.
__________________
'83 240D
Reply With Quote
  #5  
Old 04-23-2010, 11:51 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
There is a flasher unit that controls both, you should be able to locate it once you have the back of the switch in sight. Item #38.
Attached Thumbnails
Really Need to Get Turn Signals Working-console-center-stack-switches.jpg  
__________________
83 SD

84 CD
Reply With Quote
  #6  
Old 04-23-2010, 02:54 PM
Registered User
 
Join Date: Apr 2006
Location: Canada, Ontario, Hamilton
Posts: 288
1 time my signals wouldnt work, read a little on here and came across the hazards

my hazard switch was half way pushed, not on but not off, no signals working

turn the switched off and it was back no normal


aka- i second the above
__________________
1985 300D - 599,xxxk - blue interior #265 Monark Nozzle, AL129X, 15" Ronals, Gen II Big Brakes hunting
1985 300D - 491,xxxk - in prog-{A-A IC, 3" exhaust, psi\pyro, 28*BTDC, Hella Euros, IP Limiter removal
1985 300TD - 783,xxxk - parts car,used new engine with ALDA cap inplace
1987 Kenworth T-600 8LL 425 CAT Mech. - 6,000,000+k - DEI exhaust wrap, punched through resonators, 1 recent rebuild,
Reply With Quote
  #7  
Old 04-24-2010, 12:13 PM
Diesel Pusher
 
Join Date: Nov 2007
Location: Washington NC
Posts: 110
It was the hazard switch

I replaced it and BAM turn signals worked
Thanks everyone for the spot on advice.
__________________
On the hunt...
1985 300D----Sold
1985 300TD---Sold
1983 300SD---Sold
Reply With Quote
  #8  
Old 04-24-2010, 09:42 PM
Registered User
 
Join Date: Apr 2010
Location: Charleston, SC
Posts: 84
Awesome! Isn't it nice when its something simple for a change!

__________________
'83 240D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page