Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2010, 07:49 AM
muleears's Avatar
Old MB Driver
 
Join Date: May 2006
Location: Windsor, VA
Posts: 1,435
They go down but they won't go up, power windows in my W210

The two passenger side windows have no problem going down but frequently they won't come back up for several minutes or sometimes hours, regardless of how many times you push the button. I noticed it first on the front window and thought it was the switch but then noticed the rear window doing the same thing. When they finally go back up it is in one of two modes. Either they go up about a quarter inch with each touch of the button or they only go up in the non automatic (one touch) mode only. I guess my first step would be replacing the switches. On this car all four window switches are on one switch set, they have to be replaced as a unit. Anyone got any other ideas. What would cause both right side windows to act the same way? The battery had been disconnected and I thought they might be out of sync but I reset that too.

__________________

Muleears
'07 E320 Bluetec 133K my DD
'04 Jaguar XJ8 VDP, 34K
'10 Hyundai Accent 60K Grocery Getter
'02 VW Golf soon to be on the road again
'97 E300 Diesel Son's DD
'61 VERY tolerant wife

Hampton Roads, VA USA

Gone but not forgotten:
'67 250S 95K
'86 300SDL
'87 300D Turbo, 364K! R.I.P.
'98 E300 Turbodiesel, 213K
'02 S420, 164K
'01 Prius 138K
Reply With Quote
  #2  
Old 08-12-2010, 09:57 AM
Registered User
 
Join Date: Dec 2003
Location: Festus MO
Posts: 762
I'm not familiar with the W210 window switches.

Are there secondary switches located on the rear doors (i.e. for the rear seat passengers)?

SteveM.
__________________
'93 190E/D 2.5 Turbodiesel 5-speed (daily driver)
'87 190D 2.5 Turbo rustbucket - parts car
'84 Dodge Rampage diesel - Land Speed Record Holder
'13 Ram 2500 Diesel
'05 Toyota 4Runner
Reply With Quote
  #3  
Old 08-12-2010, 02:58 PM
muleears's Avatar
Old MB Driver
 
Join Date: May 2006
Location: Windsor, VA
Posts: 1,435
Quote:
Originally Posted by Jetmugg View Post
I'm not familiar with the W210 window switches.

Are there secondary switches located on the rear doors (i.e. for the rear seat passengers)?

SteveM.
There are no switches on the front doors as the switches are centrally located. There must be a switch on the back door though. I will try that switch next time the rear one screws up. Thanks for pointing that out.
__________________

Muleears
'07 E320 Bluetec 133K my DD
'04 Jaguar XJ8 VDP, 34K
'10 Hyundai Accent 60K Grocery Getter
'02 VW Golf soon to be on the road again
'97 E300 Diesel Son's DD
'61 VERY tolerant wife

Hampton Roads, VA USA

Gone but not forgotten:
'67 250S 95K
'86 300SDL
'87 300D Turbo, 364K! R.I.P.
'98 E300 Turbodiesel, 213K
'02 S420, 164K
'01 Prius 138K
Reply With Quote
  #4  
Old 08-12-2010, 03:26 PM
Registered User
 
Join Date: Oct 2005
Location: Austin TX
Posts: 352
I'm afraid I don't have any real world info on your car. But I had the same problem on my 300 sdl and it turned out to be the switch. I attempted to repair and clean the switch. (great write up on this site) but it didn't last long. I simply replaced the switch and everything worked great.

Hope this helps.
__________________
Professional greasecar installer
Austin TX


98 Jetta TDI with grease car kit + veg-therm (totaled)
87 MB 300SDL running on B99 / greasecar kit + 30 fphe
www.austingreaseguys.com
Reply With Quote
  #5  
Old 08-12-2010, 04:29 PM
koya1893's Avatar
Registered User
 
Join Date: Jun 2010
Posts: 116
If it turns out it's not the switch, it might be the plastic guide on the arm. It rides on a channel, when it seperated or broken in two pieces the arm will slide of the track completely. That's was case with mind there's a replacement peice for it. I went another route and fabricate one from 1/2" HDPE. Then I checked the remaining three window good thing I did because they were already starting to crack.
Reply With Quote
  #6  
Old 08-26-2010, 01:23 AM
Registered User
 
Join Date: Oct 2005
Location: Denver
Posts: 19
Question Part number for guide?

Quote:
Originally Posted by koya1893 View Post
If it turns out it's not the switch, it might be the plastic guide on the arm. It rides on a channel, when it seperated or broken in two pieces the arm will slide of the track completely. That's was case with mind there's a replacement peice for it. I went another route and fabricate one from 1/2" HDPE. Then I checked the remaining three window good thing I did because they were already starting to crack.
anyone know the part number for the plastic guide referenced in above post?
Reply With Quote
  #7  
Old 08-26-2010, 06:55 AM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
If it happens again, try using the key fob procedure and see if that runs them up.
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #8  
Old 08-26-2010, 02:41 PM
Renntag's Avatar
User Especial
 
Join Date: Jul 2008
Location: Kona, Hi
Posts: 1,396
Doubt its the bushing as the OP's description doesnt seem to be a mechanical type failure.
I could be wrong.

And will you guys laugh with me for a second.....Did someone really ask if the rear doors have switches? Maybe I'm the retard here.....but other than a police cruiser, when does a four door NOT have switches in the rear for the back seat occupants to operate their windows?

Seriously? (Is this a joke I am missing here?)
__________________
83 300TD (need rear wiper assembly dead or alive)
84 300SD Daily driver
85 300TD almost 400k miles and driven daily.
98 E300D *sold
86 300SDL *sold and made flawless 10 hour journey to new home.
Reply With Quote
  #9  
Old 08-26-2010, 02:58 PM
muleears's Avatar
Old MB Driver
 
Join Date: May 2006
Location: Windsor, VA
Posts: 1,435
Quote:
Originally Posted by KarTek View Post
If it happens again, try using the key fob procedure and see if that runs them up.
I have never been able to get any of the windows up with the key fob...
__________________

Muleears
'07 E320 Bluetec 133K my DD
'04 Jaguar XJ8 VDP, 34K
'10 Hyundai Accent 60K Grocery Getter
'02 VW Golf soon to be on the road again
'97 E300 Diesel Son's DD
'61 VERY tolerant wife

Hampton Roads, VA USA

Gone but not forgotten:
'67 250S 95K
'86 300SDL
'87 300D Turbo, 364K! R.I.P.
'98 E300 Turbodiesel, 213K
'02 S420, 164K
'01 Prius 138K
Reply With Quote
  #10  
Old 08-26-2010, 06:17 PM
Registered User
 
Join Date: May 2010
Location: South Alabama
Posts: 2
Ray P

Try a soft touch on your switches.
Reply With Quote
  #11  
Old 08-26-2010, 07:10 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
Quote:
Originally Posted by muleears View Post
I have never been able to get any of the windows up with the key fob...
Really? The sunroof too? You do realize you have to point the IR end of the fob at the door handle from at most 4' away and hold the button down a few seconds, right?

Not to question your intelligence...
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #12  
Old 08-26-2010, 09:01 PM
muleears's Avatar
Old MB Driver
 
Join Date: May 2006
Location: Windsor, VA
Posts: 1,435
Quote:
Originally Posted by KarTek View Post
Really? The sunroof too? You do realize you have to point the IR end of the fob at the door handle from at most 4' away and hold the button down a few seconds, right?

Not to question your intelligence...
Yup. It has never worked on my car...
__________________

Muleears
'07 E320 Bluetec 133K my DD
'04 Jaguar XJ8 VDP, 34K
'10 Hyundai Accent 60K Grocery Getter
'02 VW Golf soon to be on the road again
'97 E300 Diesel Son's DD
'61 VERY tolerant wife

Hampton Roads, VA USA

Gone but not forgotten:
'67 250S 95K
'86 300SDL
'87 300D Turbo, 364K! R.I.P.
'98 E300 Turbodiesel, 213K
'02 S420, 164K
'01 Prius 138K
Reply With Quote
  #13  
Old 08-26-2010, 10:03 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
I wonder if it's related?
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #14  
Old 03-28-2012, 12:04 AM
Registered User
 
Join Date: Jul 2004
Location: Central TX
Posts: 84
I hate to bring this post up after such a long time, but what was the solution? I have the same issue as muleears described in the original post.
Reply With Quote
  #15  
Old 03-28-2012, 12:59 AM
Registered User
 
Join Date: Dec 2011
Location: North West CT
Posts: 378
I had a 210 a number of years ago. An E430 I bought off lease w/ 50k miles. It was my wife's favorite car to date. I thought it was ok, but had some real weaknesses. One of these was the window operating systems. One of the other problems was the electrical system in general.

The windows are cable operated and not very robust. First check your electrical connectors for cleanliness. Even the act of disassembly/assembly can help. Most likely there is a problem with the cable mechanism.

__________________
Chief

1991 350SD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page