Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-05-2010, 09:41 AM
Registered User
 
Join Date: Sep 2010
Location: Central Illinois
Posts: 78
car shakes/vibrates when cold!

My 1981 240 shakes/vibrates excessively on cold start up. Its seems to decrease as it warms up. I know I have a bad motor mount, but that wouldn't explain why is lessens as the car warms up. I've also noticed after it warms up it does it less when in neutral or park. Suggestions??
__________________
1981 240D
Reply With Quote
  #2  
Old 10-05-2010, 10:21 AM
Oldwolf's Avatar
124.128/602.962/722.418
 
Join Date: Apr 2009
Location: Raleigh, NC
Posts: 1,017
Are your glow plugs working ok? I know on mine, when I have a glow plug go out in the winter, it vibrates a lot until that one cold cylinder starts firing ok.
__________________
1993 W124 300D 2.5L Turbo, OM602.962
2000 Chevrolet Cavalier, 2.4L DOHC
2002 Ford Explorer, 4.0L SOHC
2005 Toyota Prius, 1.5L

Reply With Quote
  #3  
Old 10-05-2010, 10:24 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,330
That may be the old style glow plugs, no after glow, so it takes longer to warm up and smooth out.
__________________
83 SD

84 CD
Reply With Quote
  #4  
Old 10-05-2010, 09:07 PM
Registered User
 
Join Date: Sep 2010
Location: Central Illinois
Posts: 78
Just replaced the glow plugs, so all of them are working. I noticed that my car does not have the "cigar hose"...at some point it was replaced w/ a regular fuel line. Could this be causing some of my vibration??
__________________
1981 240D
Reply With Quote
  #5  
Old 10-06-2010, 06:26 AM
mach0415's Avatar
Diesel Weasel
 
Join Date: Mar 2010
Location: Lawndale, NC
Posts: 638
Probably not. My SD is the same way, but the cigar hose is fuel return, so it does not factor in to any fuel quality issues.
__________________
Thanks,
Mark in NC
"Spark plugs?...We don't need no stinking spark plugs!"
1985 300SD "Der Silberne Schlitten" 247,000 mi
1985 300SD 359,000 mi

Wish these were diesel:
1989 Ford Ranger For Sale 170,000 mi- SOLD to a fellow Benz owner
1999 GMC Suburban 240,000 mi
2003 Ford Club Wagon 130,000 mi
1947 Plymouth 69,000 mi
Reply With Quote
  #6  
Old 10-06-2010, 07:39 AM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 23,042
your motor mount is banging on the frame. when cold the motor is not as efficient, and it can focus on issues with fuel timing and injector spray problems. when was the last valve adjustment?
change your motor mount and see how much better it smooths out.
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
Old 10-06-2010, 07:39 AM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page